Setting up drivers on a dual graphics card system

Hello, I’m trying to setup my PC environment to develop for a jetson xavier, but I’m having trouble getting the applications that I compile to run on my graphics card. I’m using a dual boot windows 10 and Ubuntu 18.04 system, and the problem only occurs on the Ubuntu system. I have two graphics cards. The card used for display is my AMD 5700 XT, and I would highly prefer to keep this card as my display card. The card that I want to dedicate to CUDA applications is a simply GTX 960.

When I run the command “nvidia-smi”, I get the following:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

It is strange, because when I check my package manager, I have the drivers version 435 installed already:


so then I check to see if the card is even connected by running “lspci | grep NVIDIA”, and I get the following result:

0c:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1)
0c:00.1 Audio device: NVIDIA Corporation Device 0fba (rev a1)

At which point, I had to stop and go to these forums, as I’m not even sure what could be going wrong at this point.
How do I get the nvidia-smi command to recognize my GTX 960?

You have the no-dkms package installed so the driver will not be built (no idea what that package is for) just remove and install the normal nvidia-headless package.
Afterwards, please post the output of
dkms status

1 Like

You were right on the money.

I ran the following commands to get the compilation working

“sudo apt-get remove .*nvidia.*”

then I reinstalled the drivers:

“sudo apt-get install nvidia-driver-440”
and I can now compile CUDA code using nsight on my local machine.