Setting up Nucleus everytime to run Isaac Sim

I’m running Isaac Sim through an AWS instance having followed the steps on the NVIDIA Isaac Sim website to set the whole thing up. Everything works well, but there’s a slight inconvenience that I face.
When I start the AWS instance, and I SSH into the instance, if I directly run the docker container containing Isaac Sim, Isaac sim opens but I get a message saying that the Nucleus is either not installed or installed incorrectly.
So what I do is I cd into the nucleus_installer folder in my AWS instance. I then run the command setup/nucelus_setup -i to install the Nucleus. Then, when I run the container, it opens up successfully without any issues.
However, I do not want to go through this Nucleus setup step. I want it to be installed always, and don’t want to do it manually ever again. How do I make sure that this nucleus setup remains persistent forever?

Hi, the Nucleus data is persistent to the instance when you run the setup on the instance. After a reboot of the instance, running setup/nucelus_setup -i will just start Nucleus again with the same data. You can script that command on boot up of the instance.

So this command does have to be run every time on boot up of the instance?
And my second question is, I’m not quite sure how to script the command on boot up. Could you point me in the right direction please?

I think you can use crontab. Try running as root:

#crontab -e

Add this line:
@reboot root <path to script>

Hi, I created a bash file called automate as attached here.automate.bash (418 Bytes)
I then transferred it to my AWS instance to the home directory. In my instance, I then ran crontab -e. It gave me 4 options to choose my editor. I chose the nano editor. It then took me to an editable file in /tmp/crontab.BdhwEQ/crontab
where I added the line @reboot root ~/automate.bash. However, even on reboot, the nucleus does not get loaded, and the docker container which should open by itself(since its written in the automate.bash file) does not open.

Try using the full path name and adding a delay:
e.g. @reboot root sleep 60;/home/user/automate.bash
Also user the full path to run the Nucleus:
e.g. /home/user/nucleus-installer/setup/nucleus-setup -i
If the Nucleus still does not start try adding this line your script:
e.g. '/home/user/nucleus-installer/System Monitor/omni-system-monitor'

To trouble shoot if the reboot command is working, after the reboot run
grep cron /var/log/syslog
You should see:

(CRON) INFO (Running @reboot jobs)

The Nucleus installer logs should be in /root/.nvidia-omniverse/logs/nucleus-setup\\nucleus-setup.log

This solution worked! Thanks a lot for your help!

1 Like