SETUP ML / Deep learning with Jetson TK1 platform

Dear community,

It is already 2 months ago since I started to work on getting my TK1 ready to run jupyter with Torch.
Since I did not manage to get it working I really want to ask the community for help.

May be it is the case that many others have this same issue…?
I can tell you what I have done:

I installed JetPack-L4T-2.3.1-linux-x64 on my TK1 and tried to install iTorch (Torch)


I tried many times and many things but I keep on getting stuck:

“Package libopenblas-dev is not available, but is referred to by another package.

Please help me with getting my TK1 setup so I can run jupyter to be able to work on ML models.
Is it possible to run PyTorch on a TK1?

Any kind of help is appreciated.

Thank you in advance.

Kinde regards



It is not recommended to use TK1 for deep learning use case since the libraries is limited. Ex. cuDNN v2.

For openblas, please install it with this command:

sudo apt-get install libblas-dev

pyTorch works well on TX1 and TX2 but we don’t test it on TK1.
You can give it a try. Here is an installation steps for your reference: