[Setup Problems] Missing dependency declarations with bazel build

Hello everyone,

I’v recently started to move to Isaac SIM from Gazebo and got stuck right after setting up the workspace.
My current situation: Installed Isaac SDK following these tutorials: Link1, Link2 and installed Isaac Sim by installing Omniverse and then installing Isaac Sim from Omniverse Exchange tab.

Problem:
Now I wanted to test my setup and compile the stereo_dummy or ping example from the Isaac SDK, however, I get a bunch of errors from bazel, when building the applications.


Mainly the same error, which is saying that there are missing dependency declarations. The files mentioned are all present within the folder. I’ve searched the web for possible solutions, but wasn’t able to solve the problem. I tried to delete the .cache/bazel folder, did bazel clean --expunge and reinstalled bazel completely. I’ve checked that the .bazelrc file is present within isaac/.

I didn’t work with bazel so far and don’t know whether there is a simple solution to this problem, like adding a line to the .bazelrc file. Something about -isystem came up during my search, but I don’t know how I would pass g++ the -isystem flag.

System
Ubuntu 20.04
Isaac SDK 2021.1
Isaac Sim 2021.2.1

Would be glad if someone could help me out
Janosch

Unfortunately, Isaac SDK 2021.1 only supports Ubuntu 18.04 which uses gcc7 by default, not gcc9 which is the default on Ubuntu 20.04. You’ll need to use the Isaac SDK development docker container (/engine/engine/build/docker/create_image.sh) or revert back to an 18.04 system most likely for the most effective solution.

Thanks for the heads up on what the actual problem is. I managed to get the SDK, Sim, Nucleus, Cache, and kit running under ubuntu 20.04 to my needs, without using Bazel and without the docker container.

Regarding the docker container, is it basically just imitating a Ubuntu 18.04 system with Isaac installed, which I’m accessing in the end? Meaning, the simulation data and all resources used need to be located within the container?
Further, I had read this Guide, but am not really sure whether this would install all Isaac software into a docker or if it’s just the SDK?

Unfortunately, I’m not able to revert back to 18.04, thus I’m searching for the optimal solution. I wanted to check out other simulators than Gazebo, as it is missing some features Isaac Sim should have. However, right now it’s rather producing more problems than it should have solved.

Best
Janosch

We didn’t quite follow what was running where in your setup. You’ll want to build your Isaac SDK application using Bazel in a Ubuntu 18.04 environment (separate machine with downgraded environment or the Docker container mentioned in the Guide you listed which only prepares the build environment for Isaac SDK applications). Isaac Sim is separate application which can run natively in Ubuntu 20.04 or in a pre-built container (here) and connects to your running Isaac SDK application.

1 Like