Shadow map not showing properly in NSight

Hi guys, I was implementing shadows in my application using shadow mapping.
I used NSight to debug the application and I noticed something really weird.
The shadow map at rendering time gets drawn properly but then in the second pass when is attached as texture and not as frame buffer it gets display completely white, even thought in the end the result is correct. This is a fairly misleading thing any idea why this would be happening?

Visual Studio 2015, GTX 960 , latest driver.

Hi giordi91,

I think your model might be placed too close to your light, that make the shadow map’s pixel value near to be 0.0.

Please try to use the histogram control of the Resources View to visualize color channels and perform range remapping for visualization. That will bring higher contrast to your shadow map. To enable the histogram control, just click on the little horizontal arrow beside your image view.