Share Ubuntu 18.04 Wifi network with Jetson TX2 over ethernet

Hi All,
My first post here:

I have set an static IP 192.168.168.200 on my Jetson device.
I would like to share WIFI internet of my laptop (Ubuntu 18.04) with the Jetson device.
I opened nm-connection-editor / wired setting and set IPv4 settings to Shared to other computers.

As one tutorial suggested my IP should now become ```
10.42.0.1


Now there is this problem I either cannot access Internet or ssh.

How can I solve the problem?
How can I start over to make Internet accessible for my Jetson device using ethernet?

You would have to enable forwarding on the Nano, and the gateway of your laptop would need to be the Nano’s IP. Is this IPv4? If so, then see what you get from:
cat /proc/sys/net/ipv4/ip_forward

If it is “0”, then try:
sudo echo 1 > /proc/sys/net/ipv4/ip_forward
…then try again. Make sure the laptop knows the Jetson’s IP is the gateway.

If that works, then consider that file “/etc/sysctl.conf” is basically a short cut method of echo to files somewhere in “/proc/sys”. So this line in “/etc/sysctl.conf” is equivalent to echo of “1” to that file:
net.ipv4/ip_forward=1

There are GUI methods of doing this as well, but basically what they will do is edit “/etc/sysctl.conf”, or perhaps adjust firewall rules as well.

1 Like

It’s easiest to use the network setting in the gui. If you follow instructions for Ubuntu 18.04 they should be more or less the same. If something differs significantly, please report it. Try these instructions:

1 Like

Thanks for your answer.
I have solved the problem by setting the default gateway on jetson device to the ip of the laptop using the command
route add default gw <x.x.x.x> eth0