Shared PCI Device missing

Hi,

i’m having an issue with our K1 Grid card. I have installed the VIB and ran the nvidia-smi command to check its installed correctly, but when i come to add the Shared PCI Device on the VDI Settings, there is no option to actually select it.

Our servers are running ESX 5.5 Build 2068190 and our VSphere Version 6.0.0 Build 2793784.

Is it that our software and OS versions need to be upgraded?

Have i missed an installation step somewhere? I’m pretty certain that i don’t need to setup pass-through as this isn’t what we are after with shared VDI pools.

Do i need to install something within VSphere to allow it to acquire the use of this new Shared PCI Device?

Does the GRID card need to be installed in the same server hosting the VSphere server?

I’ve reset the server and checked that the card is running again and still not able to see anything when looking within the settings, i’ve also tried creating a new machine in the hope that during the creation process it showed the device, but still nothing.

Any help or tips i can try will be most appreciated.

Thanks.

ESXi 5.5 does not support vGPU, so you cannot attach a shared PCI device.

If you have installed a .vib it is for VMware’s vSGA and so you have to configure the VM accordingly. Note that this is not Nvidia vGPU.

https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2033434

For vGPU ( Shared PCI Device) you require vSphere 6 or later.

If you upgrade to vSphere 6 for vGPU you must remove the vSGA .vib before attempting to install the vGPU .vib.

Thanks for the response Jason, most appreciated.

Also, if you upgrade you will need to upgrade any VM to version 11 hardware to be able to add the Shared PCI device.

If you’re creating VM’s from scratch, this will be automatic.

Jason,

I’m having the same issue, but we have vSphere 6.0 in play. The drop down only allows me to add a standard PCI device to the VMs? Any thoughts?

Jason,

I’m having the same issue, but we have vSphere 6.0 in play. The drop down only allows me to add a standard PCI device to the VMs? Any thoughts?

Check your licensed version of vSphere.

VMware requires you to have either Enterprise Plus or vSphere for Desktops.

This can occur on both Citrix and VMware as JAson says if licensing incorrect. I’m waiting on publication of VMware advice and will update thread when published. Citrix advise is already available:

• NVIDIA vGPU for XenServer is premium Citrix-licensed feature
o http://nvidia.custhelp.com/app/answers/detail/a_id/4115

Hi there,

same issue here, with M60 and vsphere 6 enterprise plus…

Any ideas then?

did you switch the cards to Graphics mode?
Which vGPU manager do you have installed?
Can you see the M60’s using NVIDIA-SMI at the esxi shell?
Are your VM’s at hardware version 11?
Are you managing the VM through vCenter?

The article on VMware licensing requirements is now available: http://nvidia.custhelp.com/app/answers/detail/a_id/4130/ not having the right license is one cause of missing profiles.

Information on checking in Graphics mode is given here: http://nvidia.custhelp.com/app/answers/detail/a_id/4106/

The VMware requirements for hardware version 11 are detailed in their documentation here: https://pubs.vmware.com/horizon-61-view/index.jsp?topic=%2Fcom.vmware.horizon-view.desktops.doc%2FGUID-CD8B9D0B-36DC-4C48-82D2-FCE10F71D48F.html

Additional Requirements for Using NVIDIA GRID vGPU

With NVIDIA GRID vGPU, a single physical GPU on an ESXi host can be shared among virtual machines. To support this type of shared GPU hardware acceleration, a pool must meet these additional requirements:
?

The virtual machines must run on ESXi 6.0 or later hosts, be virtual hardware version 11 or later, and be managed by vCenter Server 6.0 or later software.

You must configure the parent virtual machine or the virtual machine template to use a shared PCI device before you create the desktop pool in View.
?

You must install graphics drivers from the GPU vendor in the guest operating system of the virtual machine.