Shield in USB Accessory mode?

Has anyone tried to operate the Shield in USB accessory mode?

I am trying to connect to a drone controller via USB. According to the logcat, the controller is assuming it will be the host and the Shield is the accessory. I have tried to discover the device using the Android USBManager, et al. classes but it never works. If I take the same drone controller and connect to the Shield using an OTG cable (switching the tablet to the host, controller to the accessory) then I can discover the device.

One thread I found on mentioned modifying your tablet_core_hardware.xml file to include permissions for some other brand devices that could not operate in mode. I tried to modify this file using usb.accessory mode instead. When I rebooted, I was met with a barrage of errors that were so bad, I had to reimage my device.

Accessory mode seems to be a bit of black magic for some reason, there isn’t alot of info on the Internet about it. My app has all of the proper Manifest permissions for USB accessory mode, etc. and I am pretty confident I am otherwise setting up the code the proper way.