Shut-down request pin issue onJetson TX2-NX (4.6.1)

I have a problem on using TX2-NX on our carrier board.
On our carrier board using Jetpack 4.6.0, I used oscilloscope to monitor the shut-down request pin(pin number 233 on pinmux) when I shut down the device from terminal or UI interface. It’s behavior is pull down.

But while I used the same carrier board with flashing Jetpack4.6.1, the shut-down request pin’s behavior is unlike 4.6.0, it’s voltage only changed from 5.0V to ~=4.8V

I already checked the device tree , I didn’t find any difference between 4.6.0 and 4.6.1, I guess there are some difference in the driver of this pin.

Can anybody help me to analyze this issue? Thanks a lot !

Does this issue on devkit or only your board?

This issue is also on devkit.

Besides using oscilloscope to monitor the shut-down request pin, this issue affects behavior when APO mode is turned off. If APO mode off and shut down, the device can’t boot by pressing power-button.

Are you saying that you tried two different jetpack version on devkit and one version cannot put the device to boot up by using power button?

Please know that “boot up with power button” definitely has nothing to do with device tree because there is no software running when you press the button.

Yes that’s what I say, I tried not only 4.6.0 and 4.6.1, but also 4.6.2 have this issue.

When device boot up, there is a logic gate in SOM, this logic gate will get the pin-state of the shut-down request pin.
If it’s low, then the logic gate will pull high to boot.
The problem is, in Jetpack 4.6.1 , if you shut down the device, this pin would not be pull down. it only change voltage from 5.0 to 4.8. If I say something wrong, please tell me Thanks.

If I use devkit + jetpack4.6.1, how do I reproduce this issue? If I shutdown the device with “sudo shutdown”, then I cannot boot up the device again with button?

Yes, you can try by command line or using UI interface(power off in Ubuntu) to shutdown.
I used the UI interface to do it.

So if I use jetapck4.5 to shutdown device, it would be fine to boot up again with button.

But if I use jetpack4.6, then it will have this case?

No, it would be fine to boot up again with button when using Jetpack4.6.0.
But if you use Jetpack4.6.1 or Jetpack4.6.2 it will have this case

ok, so this is jp4.6.1 issue.

1 Like

We can reproduce on devkit. Will investigate this. Thanks.

Sorry for late reply.

This is the fix patch for this issue.

diff --git a/tegra186-platforms/tegra186-p3636-regulator.dtsi b/tegra186-platforms/tegra186-p3636-regulator.dtsi
index d026a18..601b0fc 100644
--- a/tegra186-platforms/tegra186-p3636-regulator.dtsi
+++ b/tegra186-platforms/tegra186-p3636-regulator.dtsi
@@ -43,9 +43,7 @@
 		shutdown-sequence = [fc 00 3c], /*cpu_en gpio*/
 			[ff 07 d0], /*delay*/
 			[3c 2f 00], /*pmic ldo6. tristate soc_vid*/
-			[3c 42 07], /*pmic cnfg*/
-			[3c 41 c0],
-			[3c 3d 00];
+			[3c 3d 00]; /*pmic GPIO7. sw_shutdown*/
 		hibernate-late-sequence =
 			[ff 17 70], /* delay to ensure cpu is off */
 			[3c 2f 00]; /* pmic ldo6 to low*/

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.