Shutting down randomly?

Hi all,

I received my jetson nano today, after setting up i ran into my first issue. During boot it randomly turns off, the power led turns off and the display output goes dark.

My first instinct is that its power related. So i switched to a samsung fast charger thats rated for 5v 2A output. after a couple of tries to boot with that it worked! i setup the computer name and everything and upon searching to see what kind of applications came preinstalled on the sd image the board powered itself off again, in the same manner.

I have tested disconnecting everything except keyboard and hdmi and that didnt seem to help. I also tried multiple power adapters (all through micro usb for now) and none of them gave me a stable solution.

After around 15 tries it usually stops during boot (it only fully booted once), it also doesnt stop at the same operation in boot so idk.

I would like to know if anyone else is experiencing similar problems, and if anyone has a solution.

My next step is going to be finding a dc barrel jack power supply thats rated at 5v 4A. if that still doesnt work i’ll try to use a different sd card and re download the image.

videos of boot:
https://photos.app.goo.gl/obH9KyiE2yCcGFiH7

power may be?
did you try with something like https://www.adafruit.com/product/1466 ?

With cell phone chargers, even the 2A kind, it is frequently the case that they do not provide a continuous, stable output at high current or the cable they use is inadequate.

Please refer to this post and the Adafruit power supplies listed there, which we have validated are up to the task: https://devtalk.nvidia.com/default/topic/1048640/jetson-nano/power-supply-considerations-for-jetson-nano-developer-kit/

I ran into this problem earlier. I’m past it now. I’ve got an Ada Fruit power supply on order, but it hasn’t arrived yet. So I was using my cellphone charge. Thankfully I also have a USB power meter. Trying several power supplies I saw that the current pull would rise to 0.5A and then the unit would cut off. I changed to another power supply and the maximum amps got a slight bit higher and then it cut off again.

Using one of the same power supplies that I had used before I used a different USB cable. When I booted this time I saw that the power usage was able to rise to slightly over 1.0 amp, but I was able to complete the boot. I’ve run into something similar with past devices and have learned from experience that not all USB cables are created equal; some of them just won’t deliver the same amount of power. I also had better outcome from a “dumb” power supply than I did with the Quick Charge ones. The dump power supply I was using is rated at 2.4A maximum.

Definitely get the Ada fruit supply since it’s what nVidia says will work. It will save time over figuring out what your power supplies and cables are doing.

Hello Marty,
i have the same issue and can confirm that changing the power supply solved the problem.

So we’re back to this again. I have the nvidia approved power adapter from adafruit. I have a powered usb hub attached and that is the only usb device attached to the nano. I did recently install an intel WiFi/Bluetooth on M.2 and it was working just fine. I noticed I got freezing issues when I had at least 5 or 6 chrome tabs open and also a YouTube connection. Maybe that’s related more to memory issues but now while going through the FAST.AI course work I get a shut down at random times. I am using a virtual machine so there is very little load on the nano so this has to be a power issue. This morning I had one chrome tab open and I was using browser based Tinkercad to do some design work and it just shut down.

I’ll keep experimenting but I fear that this will not be a useful device when it comes time to apply machine vision algos to my robotics applications. I foresee that power supply issues will continue to be a huge headache before I am forced to find another option.

Any thoughts?

I powered this kit from laboratory power supply (5V 5A) directly to pins +5V, GND on J41. My power supply has an analog ammeter, and I saw that this kit consumes energy with short pulses (more than 1 A when loading or connecting a USB device, such as a webcam). May add capacitors to smooth these pulses.

@kotmyshev Did adding capacitors resolve the issue?

@kotmyshev Yes can you give us feedback on capacitor ? I move from 12DC/5VDC to Din rail power supply and I have inconsistent shutdown (LED off)