Simnet 21.06

Based on the user guide, Simnet 21.06 requires python 3.6, tensorflow 1.15, and horovod 0.21.0. However, this horovod version is not compatible with python 3.6. Can Simnet 21.06 be run on python 3.8?

Welcome to the NVIDIA Developer forums.
I haven’t used Modulus personally - but I had a quick look on the horovod site and the summary of the 0.21.0 release and even the latest version implies it supports 3.6 and higher.
horovod · PyPI
image

When you tried what error or warning suggested that Python 3.6 wasn’t supported ?

Thanks for your response. I’m trying to install nvidia-horovod (See the attachment).

I’m using simnet 21.06, and I want to run a script using multi-gpu. I’m not sure whether I must install nvidia-tensorflow and nvidia-horovod to run simnet.

If possible, I would like to know all the packages I need to perfectly run simnet.