Simple means of keeping GTX 285 in fast mode Teapot = "work properly" button

If any recent purchasers are having performance issues with the Mac 285, one possible source of problems is the throttling back of the memory and shader clocks when the card is not in full 3D mode. The shader throttles back to 0.6GHz and the memory by a lot more. If you try MonteCarlomultiGPU just before and just after running a 3D app (like the benchmark in OpenGL Extensions manager) the result can easily be different by a factor of 10. (10k options per sec before, 100k just after, falling back to 10k via 30k after several seconds).

While we wait for an official fix, I found found that running another small Cuda app in a second Xterm window that pokes the 3D graphics does a very good job of keeping the card in fast mode. Others may have views about the best app for this, but the rotating blurry teapot (aka postProcessGL) does a good job on my 08 Mac Pro. Most of the time with this running I get about 100k options per sec, though sometimes it falls back to 70k. Screen shots tell the story without and with the teapot - see the clock speed at the bottom of the truncated deviceQuery output and the options per second figure.

Note that other people have raised other perf issues, and do not seem to have my problem on an 09 Pro - see the thread on comparison with GT120 for something completely different.

Suggestions as to better apps (less demanding - the teapot does consume resources - but enough to keep at 1.48GHz) very welcome, as would be an official control panel! Don’t forget to turn the teapot off when you are done, else you might lower card lifetime.

I have been trying out “teapot control” on another 08 Mac Pro with two GPUs: one an official Mac version 8800GT, another a GTX 260 loaded with a post-boot injector. The speed control seems most effective when the monitor is connected to the 260, as then both GPUs go to fast mode with the teapot alive. If you have the monitor in the 8800, results are less predictable (but you get a boot screen).

With the teapot up in another window, MonteCarlomultiGPU gives (GPU #0=260@1.24Ghz, GPU #1=8800@1.51Gz)

GPU #0
Options per sec.: 62226.545876
GPU #1
Options per sec.: 34650.785003

and about 20secs after you turn off the teapot, this drops to

Options per sec.: 8759.923072
Options per sec.: 4553.863701

when both GPUs are back down to 0.6GHz. Still looking for a less resource-hungry program to keep the clock up, and finer control. Not all programs benefit to quite this extent either. Histogram64 drops from 18.4s to 5.95s, but histogram256 goes the other way, 16s UP to 20s, presumably due to resource issues. So a minimal 3D program is still needed.

Same problem on MacBook Pro with GeForce 9600M GT and GeForce 9400M : the firsts launch of any CUDA application run at respectively 600Mhz/400Mhz instead 1.25Ghz/1.1Ghz and initial results are naturally deceptive!

For myself, I just launch them 3 times in one command-line, usually the first result is bad, and 2nd and 3rd are corrects.

Maybe Apple should decide to put the GPU to maximal speed each time CUDA is used, there’s no sense to launch CUDA kernel in Energy Saving mode, CUDA is for performances, exceptional performances!