Sles12 SP5 Tesla T4 driver

On sles12 SP5 I need to install the driver for an nvidia Tesla T4 card, the driver that works best is NVIDIA-Linux-x86_64-535.171.04.run but with this driver I have the following problems:

  • GUI starts randomly
  • the xrdp connection does not work correctly, after login if I press the left mouse button the display freezes

Thanks in advance

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

In attached the nvidia-bug-report.log.gz file.

Thanks
nvidia-bug-report.log.gz (268.5 KB)

Hi I tried to install Sles12 SP4 with the driver nvidia-diag-driver-local-repo-sles124-418.40.04-1.0-1.x86_64.rpm but this driver also doesn’t work, in this case I have the login page with “Oh no something has gone wrong”

SLES 12 seems to be a non-glvnd system, so you should uninstall the runfile installer and then install it again with option --no-opengl-files to not break the system libraries. Also, using dkms is advisable.

Thanks for the reply, I tried to install the driver with the --no-opengl-files but in this way the 3d appications graphics doesn’t work. If I install the driver without options the local login works (ramdomly) and the 3d application works. I also need of the opengl features.
Thanks

What do you intend to use the T4 for?

I have to use T4 for 3D earth observation software and with the --no-opengl-files option it doesn’t work

Thanks

You’re running an outdated, non-glvnd OS on a vmware esxi server with virtual graphics and want to have the a desktop on the vmware and use the tesla for 3D accel and rdp virtualgl at the same time. Might work with a lot of fiddling and work (maybe using bumblebee), rather don’t, it’s madness.

Thanks for your help! I will try with bumblebee…