[Sloved]How to make mint 18.2 interl GPU for display NVIDIA GPU for cuda?

Dear sir:
I have msi laptop with two Graphic cards:
john@john-GS63VR-6RF ~ $ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Skylake Integrated Graphics (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1c20 (rev a1)

But I only can slect one card working:
NVIDIA ( performance mode) <== select this I can call cuda
Interl (Power saving mode) <== select this I cannot call cuda, and lspci hang

I am in mint 18.2:

john@john-GS63VR-6RF ~ $ cat /etc/X11/xorg.conf
Section “ServerLayout”
Identifier “layout”
Screen 0 “nvidia”
Inactive “intel”
EndSection
Section “Device”
Identifier “intel”
Driver “modesetting”
BusID “PCI:0@0:2:0”
Option “AccelMethod” “None”
EndSection

Section “Screen”
Identifier “intel”
Device “intel”
EndSection

Section “Device”
Identifier “nvidia”
Driver “nvidia”
BusID “PCI:1@0:0:0”
Option “ConstrainCursor” “off”
EndSection

Section “Screen”
Identifier “nvidia”
Device “nvidia”
Option “AllowEmptyInitialConfiguration” “on”
Option “IgnoreDisplayDevices” “CRT”
EndSection

Thanks
John