Slow .usd animation playback

Hi, I just animated a 220k polygons plant inside Houdini and export 96 frames animation to .usd. Playing the animation inside Create is extremely choppy, while in Houdini playing same .usd file is smooth.

I wonder if I am doing something wrong and if there is any way to optimize the .usd animation performance.

Please see attached video.


2022-10-01 16-50-50.mkv (4.2 MB)

Hello @karol.osinski! Could I get some information on you system environment?

  • Operating System
  • GPU / GPU Driver

Also, if you could send us a copy of your usd file, we can take a look at it on our end. You can email it to me at

Hi Wendy!
I am not sure how but I resolved the issue by re-importing the usd from Houdini. Unfortunately I can’t remember what I have changed for the second export to work better. Maybe I deleted some unnecessary attributes.

Anyways, I am on Windows 10 , RTX 3090 , driver ver. 512.29.

I will send you the .usd anyway. Here is the link: banana.usd - Google Drive

Hello @karol.osinski
Sorry for the late reply. I think the playback speed in Create is correct. Houdini playbacks every frame, and Create playback is based on FPS.
However, the Houdini’s Realtime playback toggle seems not working as expected in LOP. If you tune the FPS to 60 in Houdini, and have the Realtime playback checked, Houdini will still run every frame while Create will play in 60 FPS speed.

I don’t think there is an option in Create allows you to playback every frame like Houdini at this moment. I will check with our internal team and request a feature if needed.

The good news is, the animation in Create is correct, that’s the animation with correct FPS you should see.

1 Like