Smart Record config does not work?

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) GeForce GTX 1050
• DeepStream Version5.0
• JetPack Version (valid for Jetson only)
• TensorRT Version7.0
• NVIDIA GPU Driver Version (valid for GPU only) 440.100

Hi,

We have set smart record=1 and we want record 60s without interval, the config as follows:

smart-record=1
smart-rec-container=0
smart-rec-file-prefix=rtsp_record
smart-rec-dir-path=output
smart-rec-video-cache=1000
smart-rec-default-duration=60
smart-rec-duration=60
smart-rec-start-time=0
smart-rec-interval=0

However, the resulting video files are not what we expected. Firstly, it has some broken files(just 1 byte). Secondly, some good files are not last for 60s, just like this:

Besides, we set the smart-rec-interval=0, but record files are not continuous, I mean, 1.mp4(10:00:00-10:00:20), and 2.mp4(10:00:32-10:00:40)

Finally, we also want the Smart Record file has the detected box and label, we tried to use -t command, but is does not work.

I’m not sure if 0 is a valid value for interval…

This is the depepstream code that uses the interval parameter: g_timeout_add (bin->config->smart_rec_interval * 1000, smart_record_event_generator, bin);

The glib help does not specify what happens if you pass a 0 interval: https://developer.gnome.org/glib/stable/glib-The-Main-Event-Loop.html#g-timeout-add.

Try leaving it out to get the default interval, which is 10 seconds.
Also you can probably lower the smart-rec-video-cache value as your start time is set to 0 - which means it doesn’t buffer/queue any frames.

Hi, Jason,

I misunderstood the meaning of the parameter, now I can meet my expectations. But I found that the record files were sometimes 52s, 54s or 58s, just rarely reach 60s. Is this a normal phenomenon?

In addition, can Smart Record display the box and label like the output-file in [sink]?

It can be a bit over or under because it needs to start on a key frame.

And yes SR can be used after inference so that the recorded files show the bboxes etc. the deepstream-test5 app however only shows SR before decoding so without bboxes.

Thank you!