Smart Record output start-time is wrong (skewed PTS) IMPROVEMENT

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
GPU
• DeepStream Version
6.0.1
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
bugs
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

When using smart record with some rtsp live sources, the PTS values in the resulting .mp4 file will sometimes be heavily skewed, causing the output video to start at invalid times.

The bug is fixed by setting the QtMux of the SmartRecord Bin start-time-selection to GST_AGGREGATOR_START_TIME_SELECTION_FIRST

First frame of the video before and after:
image
image

The improvement requires an update to the gstreamer version as the property is not avaiable in the current version shipped with the DS docker images.

For further improvement of the SR, an interface to change the behavior of the timestamping mechanism should be exposed, so that the user may opt in to setting the timestamp of the video file to the timestamp of the first frame received instead of the local unix time.

Br,

/Mathias

Sorry for the late response, is this still an issue to support? Thanks

Please check your RTSP source. We can not reproduce this issue with our rtsp source