Smart Record Settings/Behaviour

• Hardware Platform (Jetson / GPU) Jetson
• DeepStream Version 5.1
• JetPack Version (valid for Jetson only) 4.5.1

Hi all,

Been playing around with the smart recording feature and it seems that the behaviour is that it’ll record according to the intervals set as defined by smart-rec-interval. Let’s say the interval is set at 60, the flow is like this deepstream started → 1 minute wait → record for 1 minute duration → 1 minute wait → record for 1 minute duration and so on. Is this the way smart record is suppose to be?

Otherwise, would like to know if there’s a way to continuously record a single video file or multiple video files of 1minute each time from the moment deepstream app is started?

Thanks in advance!

What is your settings of smart recording? Can you post the parameters you set in deepstream config file?

There is detailed explanation of the parameters for smart recording(Smart Video Record — DeepStream 5.1 Release documentation). You can check the meaning of the parameters to know whether the behaviour matches what you observed.

hi Fiona!

These are my settings for smart record:
smart-record=2 # 0 = disable, 1 = through cloud events, 2 = through cloud + local events
smart-rec-dir-path=/home/user/Desktop/
smart-rec-file-prefix=raw
smart-rec-container=0 # 0=mp4, 1=mkv
smart-rec-video-cache=90 # video cache size in seconds
smart-rec-start-time=1
smart-rec-default-duration=60
smart-rec-duration=60
smart-rec-interval=60 #interval between each video recording

I’ve read the documentation already but I’m not able to get the desired behaviour what I want, would like to seek your advice if there is a way to get the behaviour I want instead of the one I’ve described.