Soem frames from stream1 in stream2 when using nvstreamdemux

Please provide complete information as applicable to your setup.

• Hardware Platform (jetson xavier nx devkit)
• DeepStream Version5.0
• JetPack Version (valid for Jetson only)4.4
• TensorRT Version7.1
hello everyone,I have some problems when I using pipeling for multiple streams output.
here is my pipeline

two streams into streammux -> streamdemux -> two queues -> two geltransform+gelsink, it’s a simple test.
and I got something strange:
1. I can see one or two frame from stream1 in stream2 while playing,and It’s frequently;
2. stream play is not smooth,I can see stream paused for a very short time clearly(it’s smooth without streamdemux,but I need it);

I tried local file but the same.
How can I get correct and smooth output stream ? Do I need change some settings of streammux and streamdemux?
The answer will help me a lot,thanks!

1 Like

There are some issues with the stream muxer that nvidia know about and fixes are due when DS5.0 is GA.
I find that if I set live-source=0 I get a much better result, which is counterintuitive as I’m using rtsp (live) sources…

Thanks for reply.
But live-source=0 does not work in my pipeline.
You mean the first problem is caused by stream muxer or both of them?
I think the second problem may be related to setting of pipeline, when stream is playing, it will pause for a very short time, then play faster,and then in normal speed, it’s a frequently problem.what do you think about it?
and when input is a local file,it’s pretty good, while input is rtsp, ‘reference in DPB was never decoded’ will show in console.I’m so confused

Maybe someone from NVIDIA can help you further. Setting live-source to 0 fixed a lot of the issues for me but I am still waiting for improvements and bug fixes when 5.0GA is available.

okay, thank you

Can you provide test code or command you used which can repro your issue?

Hello @cy_workmail, Did you solved the issue? I changing live-source parameter of streammux but frame miss match following stream id sometime still had there !

This has been treated with the highest priority and we are working to fix the issue and will release a patch either on the forum. Will notify on the forum, once the issue is fixed.

1 Like

Please find fix in Known NvStreamDeMux bug .

Sorry for the long delay! And, thanks all!

The DeepStream 5.0.1 SDK has been released to fix the NvStreamDeMux issue mentioned in the topics