Soft lockup when monitors are in power saving mode

Every couple of days, when I try to wake my monitors up, they will remain asleep and completely unresponsive to keyboard and mouse input. Similarly, switching to a virtual console also doesn’t work.

I wish I could provide reliable steps to reproduce the issue, but I can’t. It seems to happen entirely at random. The best steps I can give are: Allow the monitors to go to sleep. Come back hours later and try to wake them up. There doesn’t appear to be any rhyme nor reason to what triggers a lockup.

I’ve tried grabbing an nvidia-bug-report, but in the rare instances where I can SSH in, anything I try to do will give me a resource temporarily unavailable message.

The only recourse when this happens is to hard reboot the machine.

I’ve heard some rumblings that this might be due to poor UEFI implementations, so I tried in a “legacy” install and the same issue occurs.

Software:
Driver: 381.22
GNOME Shell 3.22.3
Fedora 25
4.10.14-200.fc25.x86_64

Hardware:
Monitors: Two Dell P2415Q’s connected by DisplayPort
Video Card: Gigabyte GTX 970 G1
Motherboard: GA-Z97X-Gaming GT (F7 BIOS) (Currently in ‘legacy’ mode, but also happens in UEFI)

The log file is inundated with messages similar to these:

kernel: NMI watchdog: BUG: soft lockup - CPU#3 stuck for 22s! [Xorg:2214]                                                                                                                  
abrt-dump-journal-oops[1707]: Reported 1 kernel oopses to Abrt                                                                                                                             
abrtd[1161]: fork: Resource temporarily unavailable                                                                                                                                        
abrt-dump-journal-oops[1707]: abrt-dump-journal-oops: Creating problem directories                                                                                                         
abrt-dump-journal-oops[1707]: abrt-dump-journal-oops: Found oopses: 1                                                                                                                      
kernel: Code: 00 00 48 8b 45 28 48 89 98 10 05 00 00 48 83 c4 48 5b 5d c3 00 00 55 48 89 f5 53 48 8d 5f 38 48 83 ec 08 48 89 df e8 6b 3a 00 00 <84> c0 75 3d 48 8b 53 08 48 39 da 74 3d 48 
kernel:  ? entry_SYSCALL_64_fastpath+0x1a/0xa9                                                                                                                                             
kernel:  ? SyS_ioctl+0x79/0x90                                                                                                                                                             
kernel:  ? do_vfs_ioctl+0xa3/0x5f0                                                                                                                                                         
kernel:  ? nvidia_frontend_unlocked_ioctl+0xe/0x10 [nvidia]                                                                                                                                
kernel:  ? nvidia_frontend_compat_ioctl+0x40/0x50 [nvidia]                                                                                                                                 
kernel:  ? nvkms_ioctl+0x71/0xa0 [nvidia_modeset]                                                                                                                                          
kernel:  ? nvkms_ioctl_common+0x45/0x80 [nvidia_modeset]                                                                                                                                   
kernel:  ? nvKmsIoctl+0x163/0x1e0 [nvidia_modeset]                                                                                                                                         
kernel:  ? _nv000357kms+0x2e/0x40 [nvidia_modeset]                                                                                                                                         
kernel:  ? _nv000185kms+0x40/0x40 [nvidia_modeset]                                                                                                                                         
kernel:  ? _copy_from_user+0x4e/0x80                                                                                                                                                       
kernel:  ? _nv002048kms+0x1913/0x2370 [nvidia_modeset]                                                                                                                                     
kernel:  ? _nv000009kms+0x468/0x480 [nvidia_modeset]                                                                                                                                       
kernel:  ? _nv001784kms+0x4f/0xd0 [nvidia_modeset]                                                                                                                                         
kernel:  ? _nv000724kms+0x1ff/0x2f0 [nvidia_modeset]                                                                                                                                       
kernel: Call Trace:                                                                                                                                                                        
kernel: CR2: 00000000030fe000 CR3: 00000003e510b000 CR4: 00000000001406e0                                                                                                                  
kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033                                                                                                                                  
kernel: FS:  00007fc304e4aec0(0000) GS:ffff98ff9ecc0000(0000) knlGS:0000000000000000                                                                                                       
kernel: R13: ffff98ff6b990008 R14: 0000000000000000 R15: 0000000000000001                                                                                                                  
kernel: R10: fffff86142b1b0c0 R11: ffffffffc13e3c70 R12: ffff98ff88d10808                                                                                                                  
kernel: RBP: ffff98fd5a26f408 R08: 000000000001ca40 R09: ffffffffc13d43be                                                                                                                  
kernel: RDX: ffff98fd8ff2a8c8 RSI: ffff98fd5a26f408 RDI: ffff98fe7b75c940                                                                                                                  
kernel: RAX: 0000000000000000 RBX: ffff98fe7b75c940 RCX: 0000000000fc96d1                                                                                                                  
kernel: RSP: 0018:ffffb75342727970 EFLAGS: 00000287 ORIG_RAX: ffffffffffffff10                                                                                                             
kernel: RIP: 0010:_nv001105kms+0x15/0x70 [nvidia_modeset]                                                                                                                                  
kernel: task: ffff98ff606d2580 task.stack: ffffb75342724000                                                                                                                                
kernel: Hardware name: Gigabyte Technology Co., Ltd. Z97X-Gaming GT/Z97X-Gaming GT, BIOS F7 09/19/2015                                                                                     
kernel: CPU: 3 PID: 2214 Comm: Xorg Tainted: P           OEL  4.10.14-200.fc25.x86_64 #1                                                                                                   
kernel:  snd_hda_codec_generic snd_soc_rt5640 snd_soc_rl6231 ssb iTCO_wdt snd_hda_intel nvidia_drm(POE) nvidia_modeset(POE) snd_hda_codec iTCO_vendor_support irqbypass snd_soc_ssm4567 int
kernel: Modules linked in: macvlan rfcomm xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun arc4 md4 nls_utf8 cifs dns_resolver fscache nf_conntrack_netbios_ns nf_conntrack_broadcast

If there’s any other information I can provide, I’m happy to do so! Please let me know what you need. And if anybody has any suggestions, I’m more than open to them.

Thanks!

I have seen the same issue today. @filchermcurr have you found a solution to fix it?