[SOLVED] blank screen after gdm update on 396.18

Following the configuration from my previous thread here:

https://devtalk.nvidia.com/default/topic/1037203/linux/gnome-initiates-session-blank-screen-after-login/2

After a recent update I’m just getting a blank screen. gdm3 is reporting “No screens found”. Also please note I was not able to install the driver with dkms.

Current configuration:
Linux 4.16.0-kali2-amd64 $1 SMP Debian 4.16.16-2kali2 (2018-07-04)
GDM 3.30.0

cat ~/.xinitrc

exec gnome-session

cat /usr/xsessions/gnome.desktop


X-GDM-BypassXsession=true
(to skip initializing of gnome session, refer to the thread above).

Last 2 lines in Xorg log file:
NVIDIA(GPU-0): Deleting FPU-0
Sever terminated successfully (0). Closing log file.

journal log: https://pastebin.com/7LmfUGEt
Xorg log: https://pastebin.com/xQRKYzzQ

nvidia-installer.log: https://pastebin.com/XnuuzW83
! make.log (contains errors, dkms failure): https://pastebin.com/Qj1E2KBc

Running ‘dkms build -m nvidia -v 396.18 -k 4.16.0-kali2-amd64’ returns the following:
‘make’ -j8 NV_EXCLUDR_BUILD_MODULES=’’ KERNEL_UNAME=4.16.0-kali2-amd64 modules…(bad exit status: 2)
Error! Bad return status for module build on kernel: 4.16.0-kali2-amd64 (x86_64)
Consult /var/lib/dkms/nvidia/396.18/build/make.log for more information.
(provided above)
Also somewhere among the gdm3 x-session log (which path I lost along the way) there was a no screens found error message.

UPDATE: solved the dkms error by linking /usr/bin/gcc to /usr/bin/gcc-7
mv /usr/bin/gcc /usr/bin/gcc.tmp
ln -s /usr/bin/gcc-7 /usr/bin/gcc

X is still starting with blank screen.

You have upgraded to xorg 1.20 but are running an old incompatible nvidia driver. Just upgrade that.

Well that went nice, seems I overcomplicated it. Upgraded to 390.87 and regenerated the xorg.conf file for dual GPU, worked out of the box.

@generix Thanks for looking up!