[SOLVED] Cannot connect to WiFi after apt upgrade on Jetson Nano

So, for many hours I’ve been working on trying to get my Jetson Nano to connect through WiFi using the console.

Here’s my journey so far.

  1. Follow the directions on https://developer.nvidia.com/embedded/learn/get-started-jetson-nano-devkit to download and flash the Linux system to my 128GB Evo SD Card purchased at https://smile.amazon.com/gp/product/B06XWZWYVP/ (Successfully flashed it using Etcher)
  2. Install J48 connector to use the barrel connector instead of MicroUSB
  3. In round 1 I connected my monitor, keyboard, and mouse, and successfully booted into the Nano. The WiFi connection worked just fine and I did sudo apt-get update && sudo apt-get upgrade without issue. The problem then became that Vino required me to make my account auto-log in, disable all security, and allow for random Vino connections in order to use the RDE (Remote Desktop Environment). After hours of work on trying to connect to it through my Linux Mint 19.3 host system, I decided that it wasn’t worth it and decided to chop its head off.
  4. In round 2, I flashed the OS once again to start fresh, and then I followed the tutorial at https://www.youtube.com/watch?v=Ch1NKfER0oM to get SSH up and running. Everything went well, WiFi was good to go at that time, too.
  5. I then ran sudo apt-get update && sudo apt-get upgrade again while connected to SSH. It ran, and when it updated wpasupplicant, the connection dropped. (Given that it relates to using WPA to connect through WiFi, I’m not surprised.)
  6. After that connection dropped, I successfully reconnected to SSH again, and then I did sudo reboot just to make sure everything was good to go, as I remembered that it needed a reboot after upgrading it the last time.
  7. After that reboot, the system came up, and I could use sudo screen /dev/ttyACM0 115200 on the host machine to talk to the Nano, but ifconfig shows that wlan0 wasn’t connected. I couldn’t ping google.com and get a response either.

Things I’ve Tried

  1. sudo ifup wlan0 which resulted in it complaining about the missing /etc/network/interface file. (I later gave it one, but nothing came of it.)
  2. My password contains a \ character, so I used wpa_passphrase to secure it so it’s not stored in clear text… (If I flash the card again, I’ll probably just run that command on my host machine and give it the hashed version when creating the connection through the shell GUI.)
  3. I also did a sudo dhclient wlan0 and got a bunch of endless DHCPDISCOVER messages. I couldn’t get it to cancel through the tty connection, so I pushed the reset button on the case I got for my Nano, and it rebooted.

After I made some modifications to the network config, I stopped being able to use TTY for some reason, so I’ll probably reflash to card to start fresh, but I need to know why apt upgrade causes the upgrades to stop the Wifi connection from working. What am I missing, and what other information do you need from me to figure out what’s going wrong here?

Try nmtui, nmcli or similar NetworkManager frontend after a reflash would be my suggestion.

SWEET! nmtui worked.

So, a few notions of note that I wrote as I went:

I just reflashed the SD Card, and the hashed WPA PSK didn’t work in the installer unfortunately. However, nmtui allowed me to set it as the password just fine.

As for nmtui, it comes pre-installed, so I’m taking it for a spin now. To anyone who comes across this thread, remember to use sudo nmtui, as nmtui will launch without sudo, then wait until you finish adding a connection to tell you that it has insufficient privileges. You’ll also need your MAC address which you can find with ifconfig.

BTW, Nvidia team, I noticed a bunch of useless software coming down the pipeline when I did sudo apt upgrade including Libreoffice software and Qt libraries, when those don’t make sense on a console. On login you promise us that you won’t bloat the system with that unless we run unminimize. Is there a way (aside from deliberately uninstalling them) to keep the bloat out of the system when using the console?

I don’t know if it’s important or not, but one of the things I saw scroll across the screen while doing apt upgrade is, “Installing new version of config file /etc/dhcp/dhclient-enter-hooks.d/resolved …”

Also, as the system still boots, I don’t know what’s up with this text:

Processing triggers for initramfs-tools (0.130ubuntu3.9) ...
update-initramfs: Generating /boot/initrd.img-4.9.140-tegra
cryptsetup: WARNING: failed to detect canonical device of /dev/root
cryptsetup: WARNING: could not determine root device from /etc/fstab
Warning: couldn't identify filesystem type for fsck hook, ignoring.
I: The initramfs will attempt to resume from /dev/zram3
I: (UUID=17fd1533-9bf2-4061-b182-f83af951ba7f)
I: Set the RESUME variable to override this.
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/aarch64-linux-gnu_EGL.conf: No such file or directory
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/aarch64-linux-gnu_GL.conf: No such file or directory