[Solved] deviceQuery returns CUDA driver is insufficient with latest NVIDIA gpu drivers installed

Hi, I have just started my journey in gpu programming and installed CUDA 9.2 toolkit. My machine details are as follows:

1. Dell Inspiron n5110 (notebook)
2. NVidia Geforce GT525m (compute capability 2.1)
3. Windows 7 64-bit

I have installed:

1. NVidia driver 391.35-notebook-win8-win7-64bit-international-whql (latest available)
2. Microsoft Visual Studio 2017 community edition (with Visual Studio 2015 v140 toolset)
3. CUDA 9.2 toolkit with patch update

I compiled and ran deviceQuery sample program from visual studio and the output shows:

C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.2_Utilities\deviceQuery\../.
./bin/win64/Debug/deviceQuery.exe Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.2_Utilities\deviceQuery\../.
./bin/win64/Debug/deviceQuery.exe (process 8684) exited with code 1.
Press any key to close this window . . .

I have tried to compile the nvidia sample array addition program it builds successfully but when i run it ig gives:

cudaSetDevice failed!  Do you have a CUDA-capable GPU installed?addWithCuda fail
C:\Users\Ansari\source\repos\first\x64\Debug\first.exe (process 7452) exited wit
h code 1.
Press any key to close this window . . .

I have looked on the internet, it says to install the latest drivers for CUDA 9.2 toolkit. I have already installed the latest available drivers for my gpu i.e. 391.35 What can be the problem?

CUDA 9.x does not support Fermi GPUs. Your GPU is a Fermi (cc 2.x) GPU. The last CUDA toolkit supporting that is CUDA 8.

Thanks for the reply. I have now installed CUDA 8 with visual studio 2015 community. It works fine now.