[SOLVED] dkms doesn't compil 32-compat in 64 driver.

This issue occur for a while.
Each time I enabled dkms, the sourcce tool compute only for 64 bit without any 32-compat.

Is it someone else with this issue?
Isn’t a solution for this ?

What should be compiled?
The 32bit compat libs are for X. There is nothing 32bit related to compile on an amd64-system.

That’s what I was thinking in the first place. But curiously, when compiled through the dkms process, the driver is smaller than with nvidia-installer and 32 bits software (like games) doesn’t work anymore.

Perhaps the issue has been fix till the last time I tried?

I’ll check.

I have no clue, what you are writing about.

Um dkms is only for the driver/kernel module. You don’t need to compile 32bit kernel module for 32bit games. They need 32bit libraries though.

Ok, I’ve tried again and you’re right , it works now.
But, curiously, the driver compiled by dkms is still smaller than by the installer.

It was an old issue, and apparently very old. My bad.