[solved] exception thrown: Couldn't create cudnn for DW object detect samples

Hi,

i am running into the following issue when running either sample_object_tracker, sample_object_detector or sample_object_dwdetector on Drive PX2 with the latest firmware flashed:

nvidia@nvidia:/usr/local/driveworks-0.3/bin$ ./sample_object_detector 
Program Arguments:
--tensorRT_model=.././data/samples/detector/tensorRT_model.bin
--video=.././data/samples/sfm/triangulation/video_0.h264
--yuv2rgb=cuda

Initialize DriveWorks SDK v0.3.400
Release build with GNU 4.9.2 from v0.3.0-rc8-0-g3eeebea against PDK v4.1.6.1
SDK: Resources mounted from /usr/local/driveworks-0.3/data/resources
SDK: Create NvMediaDevice
SDK: use EGL display as provided
SDK: dGPU has been detected as device number 0
SDK: iGPU has been detected as device number 1
SDK: Default GPU Device set to device number 0
SAL: identified board as DrivePX2-TegraA
SensorFactory::createSensor() -> camera.virtual, video=.././data/samples/sfm/triangulation/video_0.h264,yuv2rgb=cuda
CameraNvMedia: no seek table found at .././data/samples/sfm/triangulation/video_0.h264.seek, seeking is not available.
Camera image with 1280x800 at 30 FPS
Initializing TensorRT Network: .././data/samples/detector/tensorRT_model.bin
Driveworks exception thrown: DW_CUDA_ERROR: Couldn't create cudnn
Cannot initialize TensorRT Network: DW_CUDA_ERROR

The windows remains open and displays the video without any detection.
I also cross compiled the sample from scratch using the instructions provided and still get the same error. I made sure that the tensorRT_model.bin exists in the desired path.

Any help is greatly appreciated.

Feeling a bit stupid right now ^^

The solution is the following:

run the sample with root priviliges, e.g.

sudo ./sample_object_detector