[Solved]How to enable CP210x in Jetson TK1?


I followed all the instruction here!!!

I downloaded Kernel Source For L4T 21.5(My jetson’s L4T is 21.5)

and inserted local version “-gdacac96”


when I type ‘dmesg | grep usb’ in shell command prompt,
only I see is that all

[18438.399965] usb 1-3.1: new full-speed USB device number 28 using tegra-xhci
[18438.412601] usb 1-3.1: New USB device found, idVendor=10c4, idProduct=ea60
[18438.412607] usb 1-3.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[18438.412611] usb 1-3.1: Product: CP2102 USB to UART Bridge Controller
[18438.412615] usb 1-3.1: Manufacturer: Silicon Labs
[18438.412618] usb 1-3.1: SerialNumber: 0001


ubuntu@tegra-ubuntu:~/KernelSourceForCP210LatestVersion/kernel$ zcat /proc/config.gz | grep CP210


how can I enable it??

I solved my problem.

On your system, verify the system is R21.5 via “head -n 1 /etc/nv_tegra_release”. Then find the output of “uname -r”. Finally, was this built as a module? If so, where was the module file placed? If not, then did you install the zImage?

I input wrong local version in menuconfig.

I checked it by uname -r and correctly input local version, and it worked.