[Solved] Impassable Black Screen After Booting with GTX 780 ti, and a Korean Monitor

Hello to all at the Nvidia forums.

I have been having a difficult time getting my new EVGA GTX 780 ti (single card), with the resent Nvidia 343.22 drivers, to work on my Linux system, (Gentoo currently) for the last three weeks. I have tried to install several different Linux distributions, Arch, Chakra, Manjaro, Mageia…, to see if I could get one to work. But sadly, the only success I had was using the nouveau driver, not the proprietary. On every attempt to startx, I am greeted with a black screen; the kind when the monitor has gone to sleep (back-light on). I have been seeking the assistance of the Linux community’s forum, and currently, I have been unable to find a solution.

So far, I have a working tty1 (console) with the native 2560x1600 screen resolution using the vesa driver. The monitor, a Crossover 30Q5 Pro, is connected via DVI cable to DVI-I (primary) port to the gpu. I have had no issues with the Windows 7 partition recognizing the monitor, so I know the monitor works with the gpu. The problem I am having is when I “$startx,” or after the Grub2 bootloader tries to boot into the OS, the screen will turn off, like when it looses connection to the video card, then it turns back on to a black screen. It stays that way until I Ctl+Alt+F1, which puts me back into the tty1. Then, in order to use my command line I have to Ctl+C to exit out of what it is doing and give me the command prompt. Just recently, I came across this post here on the forums: https://devtalk.nvidia.com/default/topic/567437/no-display-on-1440p-monitor-/
which seems to be a similar issue, if not the same, to the one I am having. According to the /var/log/Xorg.0.log after running startx: “(WW) NVIDIA(0): The EDID read for display device DFP-0 is invalid: the checksum for EDID version 1 extension is invalid.”
I was wondering whether or not the file config, “Option “CustomEDID” “DFP-0:/etc/X11/g270.bin”,” would work for my monitor/configuration? If not, where could I find the appropriate EDID setting? As you can see from the xorg.conf and the 10-nvidia.conf I had tried to make adjustments to make it work, but to no avail.

Here are the logs and settings that have linked, just let me know if I am missing one that you need.
/var/log/Xorg.0.log:
https://gist.github.com/8c870ce09180b78686cf

dmesg:
https://gist.github.com/f569e3b8fdc2afce24ec

uname -a:
https://gist.github.com/b51f876449ba013571fa

/etc/X11/xorg.conf
https://gist.github.com/49eb9a843495d4de7ab1

/etc/X11/xorg.conf.d/10-nvidia.conf
https://gist.github.com/c9bfada140cf0be857d8

I don’t have a way to post the nvidia-bug-report.log.gz. I was trying to use google drive, but it only has the share option with email address, at least to my knowledge. So the best way would probably to pm me so I can email it to you. But if there is a better way, let me know.

edit: I reconfigured the files as in the other post and I am still stuck with a black screen.

Thank you for your time and help.
nvidia-bug-report.log.gz (54 KB)

I take it you tried the q270.bin from that other post. The edid for his monitor is not anywhere near like yours, so I don’t doubt it failed. You can try grabbing your EDID while booted to windows and using that for the overide maybe. Ive used a dumped edid to fake a monitor in a headless machine before, but I dumped it from nvidia-settings in linux, but you can’t do it that way right now obviously. So use windows since it’s working, The “dumper” linked below has been suggested by nvidia as outlined over there ->> http://nvidia.custhelp.com/app/answers/detail/a_id/2867/~/how-do-i-capture-the-edid-of-my-display%3F.

I assume that tool dumps it in a format nvidia recognizes since they suggest it, but I have not personally tested it. Just compare it to the edid from the post you mentioned, if it looks to be in the same format then good, if not then you will probably need to manually edit yours to match its format for nvidia’s drivers to accept it. Or you could try the route posted by tobsco in the last post of the thread you linked, by using the nouveau drivers and xrandr to grab yours, then manually create the .bin.

Monitor Asset Manager 2.9
http://www.entechtaiwan.com/files/mi_setup.exe

Once you run it select your monitor and then save it as a bin from the “file” menu. Then use that edid bin as your Option “CustomEDID” setting in xorg.conf.

I am just throwing out an idea, I’ve never had this issue or have any experience with a monitor like yours, but good luck!

Since the EDID is read over ddc, if the driver has trouble reading it under linux and not under windows (it seems windows 7 and above are using EDID by default) or with the nouveau driver, that might be related to that problem: https://devtalk.nvidia.com/default/topic/572292/linux/-solved-does-gddccontrol-work-for-anyone-here-nvidia-i2c-monitor-display-ddc/

So the same solution might work, or not, but it doesn’t take too much time to test.

Thank you very much for the reply ekrboi and alexisdm.

@ekrboi, I downloaded and installed the Monitor Assist Program and installed it on my windows partition.
I just generated the file and will use a live disk to chroot into my system and put the bin in /etc/X11/ folder. I sure hope I can get this working!

@alexisdm, thank you for the link. I am going to go over it and see what I can glean from it.

I will post when I either get it to work or face another failed attempt.

Thanks again for the help! :)

Thank you SO MUCH!!!
At long last, Success!
/etc/X11/xorg.conf: https://gist.github.com/c8951856581ff1c31347
Just to be sure, I deleted my xorg.conf.d/10-nvidia file to avoid conflicts and everything seems to be working. I wont know until I can configure my desktop/environment to see if all is well. But, now I have a working screen.

Glad to see you worked it out! Was it as simple as dumping the edid with that windows program and using it, or did you have to edit it to get it to work? Just curious in case I need to suggest it again some day.