[solved] Issue Installing Jetpack (for TK1)

Hello,

I have just received a Jetson TK1 (I am a newbie on teh nvidia forum!) and I have problem installing the Jetpack software.

I use a x86 PC, with boot from USB 3.0 key on which the linux ubuntu system is installed

jetson@jetpack:~/Téléchargements$ uname -a
Linux jetpack 3.19.0-33-generic #38~14.04.1-Ubuntu SMP Fri Nov 6 18:17:28 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Note : system packages are all up-to-date (I performed apt-get update and upgrade before trying to install the JetPack software)

file sytem info (Partition type is ext4) :

jetson@jetpack:~/Téléchargements$ mount
/dev/sdb2 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none on /sys/fs/pstore type pstore (rw)
/dev/sdb4 on /dos type vfat (rw,utf8,umask=007,gid=46)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=jetson)
jetson@jetpack:~/Téléchargements$ ^

I have downloaded the Jetpack from nvidia embeded website :

jetson@jetpack:~/Téléchargements$ ll
total 25152
drwxr-xr-x  3 jetson jetson     4096 nov.  22 18:13 ./
drwxr-xr-x 17 jetson jetson     4096 nov.  22 16:21 ../
drwxrwxr-x  4 jetson jetson     4096 nov.  22 18:14 _installer/
-rwxrwxr-x  1 jetson jetson 25742606 nov.  22 18:13 JetPack-L4T-2.0-linux-x64.run*

when executing the installer

jetson@jetpack:~/Téléchargements$ sudo ./JetPack-L4T-2.0-linux-x64.run

The GUI installer popup appears but, contrary to what is described in the quick start guide (http://ecee.colorado.edu/~ecen5653/ecen5653/doc/JETSON/Jeston_TK1_QuickStartGuide.pdf) :

  • I don’t get any step3/page 8 - Licence agreement to validate
  • it goes directly to step 4. Text message “Please specify…” is displayed but not the 2nd line “Installation directory” with associated text input. I click next… and then …
  • I don’t see the step 5 / Installation type. I just see a screen “Installing”, with message “Please wait while Jetpack L4T is installed” with extracting ressources progression bar. After a few second a terminal popup with message “Please grant sudo permission to JetPack to continue installation. Sudo access only used when needed” appears and close almost immediately without any intervention from my part
  • Around 25% progression from the installer a error popup message appear “Error occurs during installation.
    Return Code: 1
    2015/11/22 18:42:56 dialing:dial tcp 127.0.0.1:33335: connection refused”
  • when I click on ok/error popup, the jetpack installer close itself

Note :

  • wifi is connected (I use this linux computer to post in nvidia forum)
  • I have tried installation with both Jetson connected and not connected to the host linux pc through its usb cable (Jetson board looks to boot ok on its side)

Installer create a directory which contains this :

jetson@jetpack:~/Téléchargements$ ls -l _installer/
total 89216
-rwxr-xr-x 1 jetson jetson 20857632 nov.  13 10:53 Chooser
-rwxr-xr-x 1 jetson jetson  7100944 nov.  13 10:53 configure_host
-rwxr-xr-x 1 jetson jetson      957 nov.  13 10:53 cuda-l4t.sh
-rwxr-xr-x 1 jetson jetson  7048680 nov.  13 10:53 flash_os
drwxrwxr-x 2 jetson jetson     4096 nov.  13 10:53 icons
drwxr-xr-x 3 root   root       4096 nov.  22 18:14 _installer
-rwxr-xr-x 1 jetson jetson  8118616 nov.  13 10:53 InstallUtil
-rwxr-xr-x 1 jetson jetson  7075680 nov.  13 10:53 JetPack_Uninstaller
-rwxr-xr-x 1 jetson jetson 20553920 nov.  13 10:53 Launcher
-rw-rw-r-- 1 jetson jetson       30 nov.  13 10:53 local.cfg
-rwxr-xr-x 1 jetson jetson  6871192 nov.  13 10:53 nv_info_broker
-r-xr-xr-x 1 jetson jetson      204 nov.  13 10:53 ocv.sh
-rwxr-xr-x 1 jetson jetson  7660360 nov.  13 10:53 PageAction
-rwxr-xr-x 1 jetson jetson      489 nov.  13 10:53 rc.local
-r--r--r-- 1 jetson jetson      440 nov.  13 10:53 remove_unsupported_cuda_samples.sh
-rwxr-xr-x 1 jetson jetson      419 nov.  13 10:53 report_ip_to_host.sh
-rwxr-xr-x 1 jetson jetson  3028881 nov.  13 10:53 run_command
-r-xr-xr-x 1 jetson jetson      114 nov.  13 10:53 run_gameworks_sample.sh
-rwxr-xr-x 1 jetson jetson  2979526 nov.  13 10:53 sudo_daemon
jetson@jetpack:~/Téléchargements$

Any idea of what could be the issue’s cause and what could I try to fix it ?

Thanks !

I use Fedora instead of Ubuntu, so I can’t help much with JetPack. But…in case sudo has some issue, instead of starting the app with “sudo …”, try first going into an sudo shell, “sudo -s”, and then everything from that shell will always be sudo without you having to type it. No matter what JetPack may spawn, you’ll know it has sudo authority. Not likely to help, but it might, and it’s simple to test.

I don’t know exactly what JetPack requires, but the network connection refused is unrelated to WiFi or outside networking, it’s pointing to localhost on a port where presumably something is listing (something which should be running from JetPack, probably spawned as a separate thread or process). Whatever was supposed to listen locally to that port is not there.

Hi,

thanks fo the feedback !

Actually “sudo -s” does not change anything :(

I confirm that no process is listening on that particular local host port, “roughly” before and after the error

jetson@jetpack:~$ netstat | grep 33335
jetson@jetpack:~$

Have you tried the newest Jetpack?

Your edu webpage document seems to refer to some older version.

In German the umlaute always make problems, maybe the french special characters throw up issues?

Did you connect before and the .ssh RSA key has changed?

The assumptions are that there is an actual ethernet connection. I installed by powering down the device after the flash, going to where the router is then plug in an actual ethernet cable, no wifi.

This is the package that worked for me
https://developer.nvidia.com/embedded/jetson-development-pack

http://docs.nvidia.com/jetpack-l4t/index.html#developertools/mobile/jetpack/jetpack_l4t/2.0/jetpack_l4t_install.htm

Looks different in parts to your edu document.

The colorado.edu website might be the UNI that initially developed the piece so it might be outdated?

I can’t find the Téléchargements directory. Though you ‘ls -l _installer’ that directory has another _installer in it. A recursive problem?

Hi,

Thanks Ankhenaten ! You were right, the problem was lying in the ubuntu 's localisation : “Téléchargement” in french means “Downlaod”… and the “é” character must have cause the installer to fail.

I also recommend the great Jetsonhacks latest video about installing Jetpack 2.0 on Jetson TK1 : http://jetsonhacks.com/2015/11/22/jetpack-2-0-nvidia-jetson-development-pack-jetson-tk1/