[SOLVED] issue with linux 64bit driver 367.44 with GDM3

Hi guys,

i’m struggling with issues with linux driver :-(

i installed fresh Debian Jessie on my new laptop Asus GL552VX DM272T - graphics : Intel i965 + NVIDIA 3D 950M, optimus,

some things was not working correctly so i compiled kernel 4.7.4,
i got running GDM3 with distro’s drivers only on Intel with intel’s OpenGL support,
when i installed distro’s NVidia drivers version 352 from backport and started GDM3 my system is freezing when it initialize graphic card,
so i decided to uninstall everything related to NVidia driver and downloaded proprietary NVidia drivers version 367.44,
i’m able to start X correctly - there is no important EE in Xorg.log,
i setup xrand to switch correct output provider,
but windows manager in GDM3 is crashing … it writes “Oh no, something went wrong …”

i got setup Terminal as startup application, so i can write commands in graphic window,
i write “gnome-control-center” - Displays - and it writes “Could not get screen information”
i write “nvidia-settings” - and it writes that monitor is not detectable,
and it seems that my notebook’s display is identified as “eDP-1-0” , so no “HDMI” or “DP”

please could you help me to get my GDM3 working ?

Thanks for all replies ,

Kind regards,

I think the gnome/gdm packages from jessie are too old to work on optimus enabled Laptops. IIRC you need at least 3.16 and jessie has 3.14. Patches exist but you’d have to compile your own packages.

Hi generix,

Thank You for the reply …

as i wrote i’m using Debian Jessie where current kernel is 3.16 and in backport 4.6 , but i compiled kernel 4.7.4 because i had some issues with new hw with kernels in packages …

for all interested : i solved that issue … in HowTo it’s written to put xrandr commands to setup provider into .xinitrc … but in Debian Jessie with GDM3 the file .xinitrc is not executed … and that was the reason why it was failing …

if this read some admin that can add new hint into HowTo :
http://us.download.nvidia.com/XFree86/Linux-x86/319.12/README/randr14.html
and/or
https://wiki.archlinux.org/index.php/NVIDIA_Optimus

it will be good to warn users that .xinitrc may not be used in some systems and user should put commands:
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

into /etc/X11/xinit/xinitrc.d/*.sh at good order position and it will run correctly …

hope it helps somebody …

Kind regards,

My laptop panel is described as ‘eDP-1-1’ when the notebook is in optimus mode (the intel driver is used for the laptop panel), and in pure nvidia mode, the panel is DP-0.

gdm3 and nvidia in ubuntu 17.04 & 17.10 is a completely miserable experience at the moment, at least on my two Thinkpads (and judging by forums, for lots of other people). Depending on whether I use modeset=1 or not, I either get no greeter, or the nvidia driver doesn’t see any monitors (the intel driver works, so the laptop panel is visible). There hasn’t been any progress in the past few weeks and I suspect fedora has the same problem, so the coming Ubuntu and Fedora Gnome-based releases are going to be a rocky ride I think.

Since everything is great with lightdm, gdm3 is doing something wrong even when wayland is not wanted. Maybe you are on to something.

Hi Tim,

i have optimus type of hardware but i needed to do some development especially on CUDA cores hence i had to use most recent driver for NVIDIA which was not implemented into optimus work mode …

i decided to switch drivers (intel/nvidia) manually by script - my script is replacing important files and finally restarts GDM3 … this was for me only one way to have CUDA cores or energy saving intel …

if you are interested i could post that script …

Kind regards …

Hi, Ubuntu provides such a script already (prime-select they call it). Ubuntu also patches the nvidia control panel to add a GUI to swap profiles. A reboot is required going one way, and a restart of X going the other, but I can’t remember which, I usually restart.

The Fedora team is promising a new way of swapping between the two modes for the upcoming Fedora 27, with Nvidia’s support. I haven’t used Fedora before but this could be interesting.

I tried to set up the two xrandr lines but now I can’t get to the greeter at all :) I will reinstall. Honestly, I am pessimistic that Ubuntu 17.10 will work for nvidia users, gdm3 was broken in 17.04 and still hasn’t been fixed, I think they may need to consider lightdm. Certainly, I will stay on xubuntu, lightdm and xorg, I would be amazed if wayland and optimus will be ready in four weeks.

“Related to this Adam Jackson is currently working on a project he calls glxmux. glxmux will allow you to have more than one GLX implementation on the system, so that you can switch between Mesa GLX for the Intel integrated graphics card and NVidia GLX for the binary driver. While we can make no promises we hope to have the framework in place for Fedora Workstation 27.” https://blogs.gnome.org/uraeus/2017/06/20/fedora-workstation-26-and-beyond/