[SOLVED] JetPack 4.1.1 for Jetson AGX Xavier - Installation error

Good morning,

I am trying to install the newest Jetpack for Jetson AGX Xavier (JetPack 4.1.1).

After the installation (it does not appear any error) I don’t see any component installed (CUDA, TensorRT, OpenCV…). Even the Nsight is not installed in my host.

I realized it appears a message before the Jetpack installation windows is closed:

After that the Jetpack installation windows disappears.

Anyone has some idea what is happening?

Thanks!

Flash never installs extra packages. Flash itself goes over USB. After the flash the system reboots and ethernet is used for package additions. I will suggest you run JetPack again, but uncheck flash and connect ethernet. Start by checking only CUDA to Xavier. Look at the Xavier’s ifconfig and note the IP address…then enter this manually when JetPack reaches that stage (watch the console). After you get CUDA, then do the same thing with other packages without flash being set (you won’t need to reboot each package…this is only needed for flash).

If JetPack still goes away, then there is an issue.

Thanks @linuxdev! I’ve been able to sort it out!

I had the same problem when trying to flash Xavier 4.1.1.

It was several things that caused this on my host ubuntu 16.04:

  1. Running the 16.04 on vmware (worked on my TX1), the IP configuration was a mess. I had to force my host to run in NAT for it to see the 192.168.55.1 (target) and my LAN.
  2. The command sudopass was missing from my distro (dont believe it was needed to flash TX1). After installing sshpass, I was able to let my host install the CUDA libs on my target.

I didn’t have these problems flashing my TX1. I am not sure if I did something different, but I might have.