[SOLVED] Jetson TK1 and Arduino Mega 2560 Timeout Error

Hello again. I have solved GPU problem, I would like to thanks to all.

My new problem is Timeout error. On Arduino IDE program, COM doesnt show there are 4 /dev/ttyS0(1,2,3)

When I tried to upload code:

avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
An error occurred while uploading the sketch

Actually the problem is the port. These ttyS are wrong port I know but I dont know how to solve this problem. I looked this problem on internet but didnt fix. Like rebuilded the kernel, changed some files for the mega2560


when I write



Bus 002 Device 013: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter

I know nothing about the particular device, but generally speaking the lsusb shows what the USB subsystem is announcing a device to drivers in hope that a driver will take ownership of the device (the hotplug layer would have properly announced the device…it doesn’t say if the device was claimed by a driver). If a driver for this were in the form of a module, then “lsmod” would show the module loaded. Probably an easier test is to just check dmesg before and after plugging in the device…if a driver claimed ownership this will name which driver. If no driver loaded, then no ttyS would be created.

When I write dmesg:

usb 2-1.3: New USB device found, idVendor=1a86, idProduct=7523
[ 2514.648712] usb 2-1.3: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 2514.648716] usb 2-1.3: Product: USB2.0-Serial

Still same problem. I tried to comm with Arduino Genuino 101(Intel Curie Boards). I can see the port and everything but I have to setup Intel Curie Boards. When I try to install it says:

‘‘Tool flashpack is not available for your operating system’’

I tried old version but still same…

I think no one tried to use Arduino Mega or Genuino. So if i dont solve the problem, I have to use Arduino UNO…

That dmesg shows USB is working, but did not say anything about a driver being assigned. Thus you do need a driver. To see more details about what USB sees run this:

sudo lsusb -d 1a86:7523 -vvv

The “-d” uses ID “1a86:7523”, which is from your earlier post…response will be limited to just this device. The “-vvv” says to be very verbose. If you post this it might say more about chipset, but probably lsusb will only verify that there is a serial device and it needs a driver. If chipset of the serial UART can be determined (e.g., FTDI is common…and this already exists on a Jetson, so it likely isn’t FTDI), then you can work on finding out what driver is required.

Bus 002 Device 019: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0         8
  idVendor           0x1a86 QinHeng Electronics
  idProduct          0x7523 HL-340 USB-Serial adapter
  bcdDevice            2.54
  iManufacturer           0 
  iProduct                2 USB2.0-Serial
  iSerial                 0 
  bNumConfigurations      1

So I need to download HL-340 USB-Serial adapter?

Looks like only part of the lsusb was shown…sometimes due to not using sudo for extended information. The idProduct is probably a good way to look for the driver since this is what the hotplug system will broadcast to drivers. To see if it is all “custom” (versus some standard USB class…most devices have more than one part to them) you’d have to use “-vvv” and sudo.