[SOLVED][Jetson-TK1] No image captured in OpenCV hog example

I just received a Jetson TK1 (running L4T 19.2) development board and I’m trying to run some example code for hog based body detection (source: http://elinux.org/Jetson/Tutorials/Full_Body_Detection). I have successfully installed CUDA and I successfully ran some examples (source http://elinux.org/Jetson/Installing_CUDA). I also installed the pre-compiled OpenCV libraries (source https://developer.nvidia.com/linux-tegra-rel-19) and downloaded the examples. Then I followed the ‘full body detection’ tutorial (source http://elinux.org/Jetson/Tutorials/Full_Body_Detection) I was able to successfully compile the code (after removing the opencv_nonfree library from the includes) after which I tried to run the code. The code runs without error but I found it gets stuck on capturing an image from a video (the video does open, i.e. vc.isOpened()=true), specifically the following line never returns.

vc >> frame;

I tried installing some video libraries (see: http://milq.github.io/install-opencv-ubuntu-debian/) but to no avail. What can I do to fix this?

I don’t have any exact advice but 19.2 is already quite old and I recommenend flashing the 21.3 release.

I’ve updated to 21.3 and it fixed the problem! Thanks for the help kulve.