[SOLVED] [L4T 21.1] Enable USB 3.0

Just a quick question, how to edit the file extlinux.conf? I am new to Ubuntu. Thanks!

The following command should open it (Not 100% sure if gedit is the default texteditor):

sudo gedit /boot/extlinux/extlinux.conf

Then you can edit and save the file.

I also encountered the issue with grinch kernel but if i flash with original kernel i can use USB 3.0 without any issue but with grinch kernel changing extlinux.conf kills the usbport

Thanks Nilsnsn, but it seems like changing the file disable the port.

When I keep usb_port_owner_info=0 in the extlinux.conf file, USB ports work properly (USB 2.0); however, when I changed it to 2, only Bus 001 is found (as 2.0) whereas the rest disappear.

First, This issue(how to enable 3.0 in R21.1) is different from -99(started halfway in another thread) issue,
I would recommend splitting this into a new thread, for better tracking/reference/response.

2.1)Is this -99 thing not seen with Rel19.3/u-boot? and newly seen on R21.1/u-boot?
On Rel19.3 default boot loader was Fastboot, which will likely detect USB3.0 devices since boot if rootfs is not present on USB devices, and R21.1 uses u-boot which doesn’t know about USB3.0, since it’s USB3.0 firmware file is in rootfs(chicken-egee problem), if rootfs is located in attached usb devices

2.2) Does Hotplugging the USB3.0 devices make the scenario better? and does lsusb work after hotplugging USB3.0 devices?
2.3) There are some USB3.0 devices which are known to be showing issues, pls mention which device/model you are using

I only tried with R21.1/u-boot. Hotplugging does not help, Jetson knows a device has been connected, but it identifies it as USB 2.0 or as nothing (if USB 3.0 is enabled). This is the first time I try a USB 3.0, it is a e-cam80.

When i tried R21.1 installed using Install LT4 21.1 on Jetson TK1 · GitHub way, the upgrade to usb 3.0 works properly, (by usb_port_owner_info=2)

But if i try it with grinch kernel, it gives -99 error, and fails to detect anything hotplugged or otherwise, i used a keyboard, mouse and logitech camera which were otherwise getting detected (in usb 2.0) but are failing after changing usb_port_owner_info=2

I build kernel myself, and failed to enable usb 3.0 until I build firmware into kernel.

Log before fix:

[   10.573264] tegra-xhci tegra-xhci: failed to init firmware from filesystem: tegra_xusb_firmware

The fix to kernel config, also remember to copy /lib/firmware/tegra_xusb_firmware to KERNEL_SRC/firmware/


boot log will look like this

[    5.417489] tegra-xhci tegra-xhci: Firmware File: tegra_xusb_firmware (134656 Bytes)
[    5.417897] tegra-xhci tegra-xhci: Firmware DMA Memory: dma 0x80040000 mapped 0xf0047000 (134656 Bytes)
[    5.418971] usbcore: registered new interface driver usb-storage
[    5.419020] tegra-xhci tegra-xhci: XUSB device id = 0xfa3 (T124+)