[SOLVED] Multiseat with systemd and gdm and centos 7 / RHEL 7

Hi,

I have tried hard to get multiseat working on CentOS 7, systemd and gdm (and Quadro FX3800) and NVIDIA driver 340.96. But to no avail. Has anyone succeeded yet?

Joachim

Yes, I have a working multiseat with Debian, systemd and gdm.

  1. make sure your X version support the seat option with
X -h
  1. create an udev rule for your second seat.
    cat /etc/udev/rules.d/72-seat-1.rules
SUBSYSTEM=="pci", DEVPATH=="/devices/pci0000:00/0000:00:05.0/0000:02:00.0", TAG+="seat", TAG+="master-of-seat", ENV{ID_AUTOSEAT}="1", ENV{ID_SEAT}="seat1"
  1. attach your videocard, mouse and keyboard with
sudo loginctl attach seat1 path-to-your-device

more info:
http://code.lexarcana.com/posts/simple-multiseat-setup-on-fedora-17.html

success,

Floris

After I made the udev rule and triggered it, one of the graphics cards showed up in seat1. After rebooting and/or init3/init5 there was still a single seat. The xorg.0.log told me it grabbed the two NVIDIA cards and the xorg.1.log told me there was no screen left. How can I make a second X-Server start on seat1 by configuration in xorg.conf or xorg.conf.d? I tried introducing the “MatchSeat” keyword, but the NVIDIA driver does not recognize it.
Any help greatly apprecitated.

Joachim

At least I succeded! Thank you for your invaluable help, Floris!

The solution is solely in the “MatchSeat” keyword. First I tried it with CentOS 7.1 which has xorg driver 1.15. This version does not recognize the keyword. MatchSeat was introduced with xorg 1.16

(see https://lists.launchpad.net/ubuntu-multiseat/msg00251.html)

After I updated to CentOS 7.2, which brings xorg driver to version 1.17 everything worked like a charm.

Best regards,
Joachim