[SOLVED] No nppGrabcut on CUDA 8.0


I just installed CUDA 8.0.34 using JetPack 2.3 and noticed that the grabCut sample
was not built. Tried compiling the grabCut sample from a previous version and got an
error saying that the NppiGrabCut was not present.

Any idea if the library was removed or moved to VisionWorks?

Hi IgorCoelho,

The grabcutNPP sample was dropped since CUDA 7.5, since NPP library has removed that API.
This was updated in cuda samples rel notes http://docs.nvidia.com/cuda/cuda-samples/index.html#new-features-in-cuda-toolkit-7-5
The 7_CUDALibraries/grabcutNPP and 7_CUDALibraries/imageSegmentationNPP samples have been removed. These samples used the NPP graphcut APIs, which have been deprecated in CUDA 7.5.

Sorry for the late reply.


Hello kayccc,

Thank you very much for the response, and no worries about the time, was not urgent.
Was just curious because that was a sample code that I used a lot.

Well, thanks again

hello IgorCoelho,

I have installed CUDA8,and i need to use the NppiGrabCut.

Is there a alternative way the use the NppiGrabCut with the Cuda 8?

Thaks you.

Hello Zhaoxingniu,

Sorry for taking so long to answer. Unfortunately I could not find a way to use an official library so had to go to github to find some replacements.
This was one that I tried: (it has a grabcut function there)

In the end here we opted for not using grabCut but another segmentation method so this was left aside.
Sorry for not being of much help

hello IgorCoelho,
Thanks for your response.I will have a try following your advice. Thanks again.


is there an official NVIDIA solution for GrabCut in 2021 already?

I am aiming to do something like this https://answers.opencv.org/question/234209/cudacuts-for-image-texture-synthesis/ . However, I have not been able to find an implementation for CUDA 11.

I still must see if the implementation mentioned by IgorCoelho works, but I do not really expect too much as it was last updated on 2012.