Solved: no package for dkms and libvdpau

yum install cuda-drivers fails due to missing dkms package!

Tried a couple of links but can’t access them due to restrictions in my environment. Can I get the missing dkms package from any authentic source?

[b]
yum install cuda-drivers gives me an error about dkms. It says package xorg-x11-drv-nvidia-libs-390.30-1.el7.x86_64 requires libvdpau(x86-64 >=0.5

–> Finished Dependency Resolution
Error: Package: 1:nvidia-kmod-390.30-2.el7.x86_64 (nvidia-diag-driver-local-390.30)
Requires: dkms
Error: Package: 1:xorg-x11-drv-nvidia-libs-390.30-1.el7.x86_64 (nvidia-diag-driver-local-390.30)
Requires: libvdpau(x86-64) >= 0.5
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest[/b]

Thanks,
Karan

You may get dependency from http://rpm.pbone.net/index.php3/stat/4/idpl/30427867/dir/centos_7/com/dkms-2.2.0.3-31.1.noarch.rpm.html

dkms is available in the EPEL repo:

https://www.tecmint.com/how-to-enable-epel-repository-for-rhel-centos-6-5/

https://centos.pkgs.org/7/epel-x86_64/dkms-2.4.0-1.20170926git959bd74.el7.noarch.rpm.html

EPEL repo is installable with

yum -y install epel-release

Thanks Andrey1984 and nvidia.

Got it fixed and the driver is successfully installed and running :)

dkms and libvdpau x86_64 were required to fix it.
got,

  1. dkms from [http://mirror.de.leaseweb.net/epel/7/x86_64/Packages/d/dkms-2.4.0-1.20170926git959bd74.el7.noarch.rpm]
  2. libvdpau from [https://rpmfind.net/linux/rpm2html/search.php?query=libvdpau(x86-64)]

**Note: libvdpau package available in the EPEL repo doesn’t work! [http://mirror.de.leaseweb.net/epel/7/x86_64/Packages/l/libvdpau-va-gl-0.4.2-6.el7.x86_64.rpm]