[Solved] Nsight 4.5, VS2012 - CommunicationException (IP=0.0.0.0)

I’m running a GTX760 @ driver 347.52, Windows 8.1.

nsight.log:
Error,02/18/2015 09:13:14,Nsight.Monitor.exe,’’ id: 1,Ark,"EndInvokeOnThread Exception : System.ServiceModel.CommunicationException: A TCP error (10013: An attempt was made to access a socket in a way forbidden by its access permissions) occurred while listening on IP Endpoint=0.0.0.0:8000. —> System.Net.Sockets.SocketException: An attempt was made to access a socket in a way forbidden by its access permissions

Considering the IP (0.0.0.0), I’d guess it’s related to not being able to find the correct network device. I tried to change the connection name from localhost to LAN ip/name under launch options, but it made no difference. Still says 0.0.0.0. The monitor is not being blocked by firewall either, although that still wouldn’t explain the IP. I’ve tried running as admin, both from visual studio in admin mode and the monitor app itself as admin.

Any ideas?

Hi,

Hard to say why, but maybe you can try these:

  • change to some other port number, in case 8000 already been used by some other app
  • check your firewall, it may block port 8000
  • anti-virus softwar?

Maybe you can use netstat -a to confirm the port usage.

Thanks
An

Hello, and thanks for your reply.

I did a netstat -a -b and found this:

TCP 0.0.0.0:8000 WorkMunstar:0 LISTENING
Can not obtain ownership information

I then went into tcpview:

System 4 TCP WorkMunstar 8000 WorkMunstar 0 LISTENING

Googling then led me here: http://superuser.com/questions/360236/why-is-system-listening-on-port-8000

Which didn’t really illuminate the culprit. In any case, changing the port would work. But the monitor app dies after displaying that error message. I could get to the options screen before closing the error message, but changes didn’t save. What worked was to manually change the port in Common\ModelDefinitions\Monitor.General.nvmodel. Now it’s running and it’s all good. :)

Hi Xeethrax,

Glad it works for you, :)

Thanks
An

Just note for anyone on Windows 8, the directory is “C:\Program Files (x86)\NVIDIA Corporation\Nsight Visual Studio Edition 4.5\Monitor\Common\ModelDefinitions” for Xeethrax’s solution.