[SOLVED] nvidia 418.56 - GDM Not starting on kernel 4.19

I have 2 GPUs (already tried removing one of the GPUs and gdm is still not starting). It freezes with a blank screen.

The main card on the box is Geforce GTX1080TI. I already tried removing one of the GPUs and booting the system with just one of the cards.

System: Linux kali 4.19.0-kali4-amd64 #1 SMP Debian 4.19.28-2kali1 (2019-03-18) x86_64 GNU/Linux

(GDM is with debug mode enabled)

journal log:
https://pastebin.com/9dUSXZGQ
https://pastebin.com/PJQYT3UA
https://pastebin.com/pUhZ5CzL

Xorg.0 log:
https://pastebin.com/wqyT5tg5

xorg.conf (generated by nvidia installer)
https://pastebin.com/3jCZt6Nv

Looks like the usual GDM madness, it sets up an X-session which comes up fine but then tries to connect to wayland. Try removing nvidia-drm.modeset=1 from the kernel parameters.

@generix still not booting. Now it freezes on “Started update UTMP about System Runlevel changes”. Also tried setting X-GDM-BypassXsession=true in /usr/share/xsessions/gnome.desktop with no effect. Any suggestions?

Did you already disable wayland in gdm config?

Yes, I have already done that on one of the previous configurations where X worked for this box (kernel 4.15). Actually something quite strange happened while typing this as I just reverted the original daemon.conf file in /etc/gdm3 (where WaylandEnable=false is disabled) and the GDM GUI just started! Go figure…

Screw that, you have a broken Xserver setup, the glx module is still 1.19, the Xserver 1.20. Please reinstall the xorg-xserver package.

So for anyone following up this thread, the configuration is as follows:

/etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nvidia-drm.modeset=1”

/etc/gdm3/daemon.conf - default configuration file as gdm3

[daemon]

WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]

More verbose logs

Additionally lets the X server dump core if it crashes

#Enable=true

The differences to prior /etc/gdm3/daemon.conf configuration are as folows:
[daemon]
WaylandEnable=false

[security]
AllowRoot = true

[xdmcp]

[chooser]

[debug]

More verbose logs

Additionally lets the X server dump core if it crashes

Enable = true

@generix I already reinstalled the xserver-xorg package several times. May be purge? Also where are you seeing the version inconsistency?

It’s in the xorg log right at the start:

Apr 03 09:07:55 kali /usr/lib/gdm3/gdm-x-session[785]: X.Org X Server 1.20.3
...
Apr 03 09:07:55 kali /usr/lib/gdm3/gdm-x-session[785]: (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
Apr 03 09:07:55 kali /usr/lib/gdm3/gdm-x-session[785]: (II) Module glx: vendor="X.Org Foundation"
Apr 03 09:07:55 kali /usr/lib/gdm3/gdm-x-session[785]:         compiled for 1.19.6, module version = 1.0.0

should be in the xserver-xorg-core package
https://packages.debian.org/de/sid/xserver-xorg-core

@generix not sure how to double-check this as X is now starting fine and not generating a log file. Is there a way to double-check it again from another place?

IMO the whole mess was because of the altered gdm3 configuration file and the commented WaylandEnable=false setting

Everything seems to work fine now, thanks for paying attention to this.

sudo journalctl -b0 --no-pager _COMM=gdm-x-session
spills out the xorg log.

journalctl -b0 --no-pager _COMM=gdm-x-session

– Logs begin at Wed 2019-04-03 13:24:26 EDT, end at Wed 2019-04-03 13:26:10 EDT. –
– No entries –

also just figured out nvidia-drm.modeset=1 should be removed from the kernel options, otherwise the monitor does not wake up from blank screen, probably related to the following bugs:

https://forums.geforce.com/default/topic/1079839/geforce-drivers/all-driver-400-version-and-monitor-sleep-and-wake-issue-/

https://forums.geforce.com/default/topic/1079109/geforce-drivers/corrupted-vertical-lines-possibly-when-waking-up-display/