[SOLVED] nvidia 418.56 on kernel 4.16 blank screen after update (gdm fails to start on dual-gpu)

kernel 4.16.0-kali2-amd64
nvidia 418.56
nvidia-drm.modeset=1 in /etc/default/grub (already tried without this option at boot)
driver installed with --no-cc-version-check option and registered with dkms

X-GDM-Bypass-Xsession=true is set in /usr/share/xsessions/gnome.desktop (tried removing it)
WaylandEnable=false in /etc/gdm3/daemon.conf

optimus.desktop (in ~/.config/autostart/ and /usr/share/gdm/greeter/autostart
[Desktop Entry]
Type=Application
Name=Optimus
Exec=sh -c “xrandr --setprovideroutputsource modesetting NVIDIA-0; xrandr --auto; logger setOptimus”
NoDisplay=true
X-Gnome-Autostart-Phase=DisplayServer

/etc/X11/xorg.conf configured for dual-gpu mode with drivers “nvidia” and “modesetting”

The above configuration with X-GDM-BypassXsession=true and nvidia-drm.modeset=1 WaylandEnable=false worked with the same kernel and driver 390.87

Current configuration for the logs below:

nvidia-drm.modeset=1 in /etc/default/grub
WaylandEnable=false in /etc/gdm3/daemon.conf
X-GDM-BypassXsession=true in /usr/share/xsessions/gnome.desktop

xorg.conf:
https://pastebin.com/ugr36wiH

journalctl -b 0 --no-pager:
https://pastebin.com/5wJCdr7S

Sounds like the same problem with the wrong glx module, tried reinstalling xserver-xorg-core?
This is a known problem when using the .run installer and upgrading simultaneously the xserver from 1.19->1.20 and the nvidia driver from <410 -> >=410.

From log:

Apr 05 13:53:01 x1234 /usr/lib/gdm3/gdm-x-session[1092]: (II) Module glx: vendor="X.Org Foundation"
Apr 05 13:53:01 x1234 /usr/lib/gdm3/gdm-x-session[1092]:         compiled for 1.19.3, module version = 1.0.0
Apr 05 13:53:01 x1234 /usr/lib/gdm3/gdm-x-session[1092]:         ABI class: X.Org Server Extension, version 10.0

@generix this is on another box, a notebook with intel integrated and GeForce GTX 960M
Just reinstalled the xserver-xorg-core package, X now started, waiting to make some checks

Update: still requires X-GDM-BypassXsession=true to be set in /usr/share/xsession, otherwise X starts but once you get past the login screen the screen flickers and goes back to blank screen.

With the previous configuration and reinstalling the xserver-xorg-core package this seems to have fixed it.

Thanks, I appreciate your attention into my recent threads!