[SOLVED] [OBSOLETE] Hosed my tk1

I managed to Bork my file system. How? I forgot the -S 8 gib switch. It flashed to a 1.6gb partition which didn’t have enough space. To compound my stupidity, I erased all files on that partition. Now, every time I flash l4t 19, the board reboots into unity and no the shell Luke when I first got it. Any ideas? Thanks.

The initial file system was missing the GUI packages and I think the readme instructs to install them as the first step. After that it would boot to Unity as well.

What’s the problem in booting to GUI or with the new l4t release?

I haven’t dug deeply, but i can’t start anything that brings up the software window. i’m not at the board right now but it says something to the effect the ubuntu 14.04 encountered an error. you may have to reinstall. looking at the details it says unsupported package, which I expect. The software did work before i messed it up.

I’m thinking there is an existing partition somewhere that i’m missing. Even the T4L instructions say you should have to apt-get the unity desktop and that it should boot to shell after first install. That’s what’s bugging me.

If you have the L4T installed correctly, in the home direcotory, there should be a directory called NVIDIA-INSTALLER. Go in there, run “sudo installer.sh”, then when that is done, reboot. Then you should have your GUI. It takes 10-20 seconds to configure itself the first time, so be patient.

It’s not there. Just ubuntu. Like it’s already been run. I’m about to fire up my linux box and look again at the file system I extracted.

The rootfs that’s available for download (Tegra_Linux_Sample-Root-Filesystem_R19.2.0_armhf.tbz2) does not include the NVIDIA-INSTALLER directory. I’m not sure where that comes from, but before I’d done any type of modifications I’d backed that directory up on another system. I know that doesn’t help you, but it would be nice if that was posted somewhere from nVidia, or if someone knows the link. I was reading through the license, and I believe it’s okay to tar it up and host it for download, but I’m definitely not a lawyer nor a license specialist, so I’d rather avoid doing so myself unless I saw someone explicitly say that it’s allowed (from nVidia).

Kinda what I figured. I’m slowly sorting it out. There appear to be some permissions missing. As soon as I get enough fixed to install chromium, I’ll post from the box.

And oh my god this usb 3.0 power thing is going to kill me. Mouse and keyboard always sleeping

ok. i’m up and running thus far. even got arm chromium installed. here’s what i did:

sudo ./flash.sh -S 14580MiB jetson-tk1 mmcblk0p1

commands run after flashing the 14580MiB

sudo apt-get update
sudo dpkg --configure -a
sudo apt-get update
sudo apt-get upgrade
sudo date -s "4 jun 2014 19:54:00"
sudo apt-get --fix-missing install
sudo apt-get install -f
sudo reboot
sudo chmod o+x /usr/lib/dbus-1.0/dbus-daemon-launch-helper
sudo reboot
sudo reboot
apt-get install exfat-fuse

not sucessful YET:

echo "options usbcore autosuspend=-1" > /etc/modprobe.d/disable-usb-autosuspend.conf
echo -1 > /sys/module/usbcore/parameters/autosuspend
sudo bash -c 'echo -1 > /sys/module/usbcore/parameters/autosuspend'

sources

Error: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program /usr/lib/dbus-1.0/dbus-daemon-launch-helper: Success

The cause of this proved quite difficult to track down. Eventually a Gentoo forum post led me to the solution. It seems that somewhere along the line, dbus-daemon-launch-helper has ended up with the wrong permissions. Change its permissions to be world executable.

chmod o+x /usr/lib/dbus-1.0/dbus-daemon-launch-helper