[SOLVED] pip for python not working

I installed pip, a package installer for python on my Jetson with “sudo apt-get install python-pip”, and all seemed to go well.

When I try to use it, however, by typing “sudo pip install rpyc”, it fails.

It mentions a site (https://pypi.python.org) that complains that the security certificate has expired when I try to go there using a browser on the Jetson.

When I try to go there in Windows or in x64 Linux, it works fine. Using pip works fine as well.

Is something on my Jetson screwed up, or is there really problem with the pip web server? I have been retrying this for several days, but no luck. It used to work OK on a different Jetson board. Can someone out there try pip on a Jetson for me?


On Fedora things are fine when browsing this site, including certificates showing as valid. Under R21.2 with no modifications, firefox reports “This Connection is Untrusted”. If in firefox I disable “block reported web forgeries” the site is then allowed. Once on that page, I can re-enable “block reported web forgeries” and it works just fine after that.

It seems that either firefox on L4T or something related to firefox is handling SSL certificates differently than non-L4T. My non-L4T system is Fedora, so I don’t know about x86/x86_64 under Ubuntu.

Following this test with firefox, I was able to install python-pip and run pip install rpyc with no errors. I did not try any of the python install before using firefox, so I don’t know if python update would have failed before using firefox or not.

I would suggest you open firefox, go to the URL you gave, and see if it fails. Assuming it does, go into the preferences security section, temporarily disable blocking of web forgeries, reload the page, and then re-enable blocking of web forgeries to see how it works.

Wow, that was fast! Thanks, I’ll give it a try when I get home tonight.

I noticed the Firefox warning was reporting a date with year of 1970. It makes me think there is an uninitialized variable somewhere. Maybe successfully loading the page initializes the variable somehow, and then pip works. Just a guess.


If the clock on Jetson gets reseted to 0 (i.e. 1970) then all the SSL certificates will be invalid and https won’t work. Easiest way to fix that is to set the clock. In some cases you may also tell the application to ignore the invalid cert but that of course has its own risks.

Yep, you are right. It was MY clock that was messed up, and not the web-site’s. This was causing all my problems.

It turns out my RTC module is acting weirdly, and takes a long time to ‘kick in’ after boot (at least a minute or two) even though I am calling ‘sudo hwclock -s -f /dev/rtc0’ in my rc.local file. Any ideas?

Thanks for the help!

You may install “ntp” or “ntpdate” packages. “ntp” keeps the clock in time and “ntpdate” sets the clock on boot based on public time servers in the net. Downside is that they need network already during the boot.

I’ve discoverd how to fix the initialization of my RTC module.

In my /etc/rc.local file I had commands to mess with the CPU and GPU clocks immediately before the commands to initialize the RTC. I tried moving the initialization of the RTC to the beginning of the rc.local file, and now all works fine.