[Solved] Startx got emoji like smily faces on screen

Hi dears,

I’m using startx to run my wm on my Linux system,but I got many smily faces on my screen, instead of running wm what’s the issue is? Its Looks like emoji, and I don’t know how to describe it.

Thanks.

Take a photo?

just took the photo.

Nice but puzzling.
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Thanks for your help, just attached the report.
nvidia-bug-report.log.gz (927 KB)

The gpu is hanging on mode switch:

Feb 01 00:07:22 gentoo kernel: nvidia-modeset: WARNING: GPU:0: Lost display notification (0:0x00000000); continuing.

Do you have one or two monitors attached?
In your xorg.conf you have

Option         "metamodes" "DP-0: nvidia-auto-select +0+0, DP-1: nvidia-auto-select +0+1080"

but there’s only one monitor detected. Please comment out that line and try to start X. In case you really have two monitors attached, try with just one after another.

Interesting. Does the problem go away if you configure your bootloader for a graphical framebuffer console?

Edit: Can you please also try the 418.30 release to see if the problem still occurs?

I have two monitors before, but now I just have one monitor on the laptop.
And I created new config from nvidia-config, still same issue.

Yes I do configured the bootloder framebuffer, looks not work.
It’s so strange that I can run WM sometimes but some time it’s not work.
I’m using gentoo port to install the driver, need find out how to install 418.30, my current version is
415.27

I’m not sure if it’s related with some kernel config.

Gentoo just upgrade to 418.30, I did around 20 times test, looks work good now.
Thanks.