[Solved]UI not loading on Jetson TK1 after flashing with Grinch 19.3.6

Good day,

I’ve flashed my Jetson with the newest Grinch kernel (19.3.6), after reboot the UI comes up; but the UI display quality is poor. When I turn off and restart the system again it loads until the Nvidia logo and the screen stays black. I can see the screen is on but the UI is not showing.

I’m able to communicate with the Jetson on the host computer using

ssh ubuntu@tegra-ubuntu

and I’m able to view the Jetson ubuntu folder as when I type in command

sudo ssh -X ubuntu@tegra-ubuntu nautilus

I also tried fixing the problem by:
restalling lightdm,
installing gdm and reconfiguring to gdm.

The host computer I flashed the kernel on is Linux Ubuntu 12.04 64bit in VirtualBox.

Does your virtualbox have a native linux file system under it, like ext3 or ext4? Or does it run on top of a windows or Mac native file system? For flash to succeed you MUST preserve permissions on host…this is an absolute must. You can run as root or sudo for root authority, and then lose it all if the file system under it does not understand linux.

It runs on top of a windows filesystem. Thank you Linuxdev. I will reflash the dev board on a native linux PC. I didn’t know that would be a problem

The PC can be virtual, but the filesystem under must be native…just requires you have a partition dedicated to linux.