[SOLVED] Unable to change "CUDA_DEVICE_ORDER"

I need to be able to set CUDA_​DEVICE_​ORDER to “PCI_BUS_ID”, but every time I type:

export CUDA_​DEVICE_​ORDER=PCI_BUS_ID

I get:

bash: export: `CUDA_​DEVICE_​ORDER=PCI_BUS_ID': not a valid identifier

I was able to run that as a super user, but the changes don’t stay for other users.

If that’s not possible, for some reason, we need to be able to identify which GPU is used to display. We’re developing a multi-GPU app with OpenGL rendering and we gave the option to reduce the amount of computation done by GPU-0 to give it more time to render.

So either solution would be good for us!

Thanks,
Jack

There are apparently multiple underline characters in this particular character set. The one you are using is not valid for an identifier.

Did you copy and paste any of this text? If so, manually just type:

export CUDA_DEVICE_ORDER=PCI_BUS_ID

and see what happens (I think if you copy and paste my text above, it should work also)

SOLVED!

Thanks txbob