[Solved] UX32VD: "Unable to copy VBIOS to system memory"

Hello,

I have an issue with my laptop, an Asus UX32VD, which contains an Intel and an NVIDIA card. I cannot start X with the nvidia driver. I just get this dmesg output:

[  394.257053] vgaarb: this pci device is not a vga device
[  394.258602] nvidia 0000:01:00.0: irq 48 for MSI/MSI-X
[  394.279766] NVRM: failed to copy vbios to system memory.
[  394.285849] NVRM: RmInitAdapter failed! (0x30:0xffffffff:720)
[  394.285872] NVRM: rm_init_adapter failed for device bearing minor number 0
[  394.285927] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5

I’m running Debian Wheezy on a 3.13.0 kernel and the 331.38 nvidia driver. Also patched the installer archive according to the information I found in this link: https://devtalk.nvidia.com/default/topic/644906/331-20-on-3-13-rc1-kernel/#4065377

Booting my 3.2 kernel works out of the box with the same (patched) nvidia driver, so there is definitely something going on with the system configuration.

I have also attempted to enable UEFI CSM boot without success. Would be great to get some pointers as to what I can do. NVIDIA bug report can be downloaded here: http://krisrst.no/

I solved this issue myself. The problem, according to the blog below, was that I had to do more patches than those mentioned in my post above. (Apparently because I was not running EFI/CSM)

Blog link:http://blog.langfinger.org/?p=314
I copy the patch I used from that blog to my server for future reference:
http://krisrst.no/nvidia_3.13.0/patch

Can confirm this works on 3.13.1 kernel.