Speed difference for same CUDA code under Windows/Linux

We have some news: NVIDIA staff over at nvnews have acknowledged the issue, and claim that the next beta release may fix it for all GT240/GDDR5 folk…

Read the relevant replies here (bottom 4 posts, and first ones on the next page (page 6)

Here’s hoping…

Just tried the 195.36.08 certified driver. For my GTX 260M, the powermizer bug still exists. No improvement for tests such as 3dfd.

Before that, I was using 195.17 beta driver. The newly released one seems to be a bug fix version.

Have you tried manually overriding the power levels in xorg.conf?

Try adding this to the Device section for your GT2x0 GPU:

Option          "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x1"

No, these settings (and a myriad other combinations on them that can be tried - I dare say I tried all of them :-) don’t work in the GeForce 200 series - e.g. my GT240/GDDR5, or meng’s GTX260M. There is hope, though, because AaronP (from NVIDIA) said on nvnews, at 27/2/2010:

“There was a change that went in just after the current beta release that may fix the problem. Please try the next beta release.”

This means that the beta after 195.36.08 is the one that we are hoping will finally solve the powermizer bug.

Fingers crossed…

Yes! :-)

The latest beta, 195.36.15 finally closes the huge performance hole that existed for GT240/GDDR5 cards…

I can verify that with the new driver, the difference between Windows and Linux is now negligible:

bash# echo | ./bandwidthTest  | grep -A1 Bandwi | tail -3


Transfer Size (Bytes)   Bandwidth(MB/s)

 33554432			   26683.4

This used to score around 8000 in the previous drivers - now it is just as fast as it is under Windows.

Thanks to everyone at NVIDIA that worked on this, and a thank you to the people that joined me in complaining about this bug :-)