SPI pins not working in Jetson nano developer kit 4GB


I’m using Jetson Nano Developer kit 4GB with jetpack v4.6.1 and I’m having trouble in enabling the SPI pins (SPI1).
I enabled the SPI pins using ’ sudo /opt/nvidia/jetson-io/jetson-io.py ’ command and I ran the command ’ ls /dev/spi* ', all the 4 Spidev folders were available.
Further I got the know that to use SPI pins I should disable the GPIO pin functionality, I followed the steps as mentioned in this thread :
I manually downloaded the kernel and extracted it, I was not able to find tegra210-porg-gpio-p3448-0000-b00.dtsi file. Then I tried to build the kernel (more than 2 times) but everytime resulted in the following error :
Error: Missing kernel image /home/sr/Linux_for_Tegra/source/public/kernel_out/arch/arm64/boot/Image.

Is there any other methods or am I missing something. Any suggestions would be appreciated.

Thank you.

1 Like

Hi gayathri.l,

I would suggest updating to latest R32.7.4 to verify.

You could also dissemble the dtb in use and modify the device tree to remove the GPIO usage for SPI pins.
Could you help to provide the flash log for further check?

Hi Kevin,

Actually I again flashed OS to Jetson nano and upgraded it to the version R32.7.4 .
I followed all the steps from scratch. Manually downloaded the kernel and tegra210-porg-gpio-p3448-0000-b00.dtsi file was available in this path
Modified the above file and the used spidev-test to test SPI which was unsuccessful.
And I tried to build the kernel but resulted in same above error.

The Linux_For_Tegra folder is located in /home/jetson-nano/ , does the path matter while we build kernel?

When i ran dmesg command, I got the DTS file as :
[ 0.219972] DTS File Name: /dvs/git/dirty/git-master_linux/kernel/kernel-4.9/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t210/porg/kernel-dts/tegra210-p3448-0000-p3449-0000-b00.dts

As you requested previously for flash log, is the kern.log file you are looking for? If not kern.log file please, explain me how to get the flash log as I’m new to Jetson nano.

Thank you.
kern.log (575.6 KB)

Do you download the BSP package on your Jetson device…?
BSP package should be handled on a standalone Ubuntu 18.04 host PC.

Flash log is the log during flash the board.
You would flash the board from a host PC, there would be the log showed on your terminal of host PC, and that is flash log.

So we need to flash the board from PC that has Ubuntu and not on the Jetson Nano which had OS that was flashed from Windows PC.

Should we re-flash the board using the SDKM software using Ubuntu PC to get flash logs?
Is this the link to be followed - https://docs.nvidia.com/sdk-manager/install-with-sdkm-jetson/index.html where Export Debug Logs gives the flash log which is required ?

Correct, you need to get a Ubuntu host PC to develop Jetson device.

Yes, flash log would be included that .zip file exported from SDKM.

Hi Kevin,

I have a Windows PC so, I tried Virtual Box with Ubuntu OS, but was unsuccessful.
In VM, the SDKM was not able to detect the board.
I even set the Jetson board to recovery mode by connecting PIN 3 & PIN 4 together later powering it using USB. But no luck.

Please suggest some alternatives or work-arounds to solve this issue.

Thank you.

VM/docker/WSL2 may have connection issue with Jetson device.

Please get a standalone Ubuntu as your host PC.
If you have only one Windows PCl, please try to make dual boot for Ubuntu.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.