SPI slave implementation in Jetson Nano Dev kit


I’m trying to implement Jetson Nano as SPI slave device.
I need to configure SPI Port0 as slave in Jetson Nano.

My SPI Host (Master) works with CLK speed = 1.5MHz, Data size = 16bits, CLK_POL = 0, CLK_PHA = 0, DataFormat = MSB first.

Below were the changes I made in “tegra210-p3448-0000-p3449-0000-b00.dts” dts file:

    spi@7000d400 {
            compatible = "nvidia,tegra210-spi-slave";
            status = "okay";

    spi@0   {
            status ="okay";
            spi-max-frequency = <1500000>;


    spi@1   {
            status = "okay";
            spi-max-frequency = <1500000>;


I builded and flashed the code into Jetson Nano. But still it looks like Jetson Nano working as SPI Master.

Please let me know do I need to update any other parameters to configure the SPI slave in Jetson Nano?

I tried to check spi driver is enabled or not by using the below command
~$ dmesg | grep -i spi

[ 0.441260] iommu: Adding device 7000d400.spi to group 7
[ 0.441526] iommu: Adding device 7000d600.spi to group 8


I’m looking forward to hearing from you.

Thanks and Regards

Hi mohan.c,

What’s your Jetpack version in use?

You could refer to the following thread to configure SPI as slave.
SPI0 interface configured as a slave in Jetson Xavier NX - #10 by borjabasket14

Hi Kevin,

I’m using NVIDIA L4T 32.6.1 Jetpack version.

Could you help to update to latest R32.7.3 and verify?

Hi Kevin,

I tried flashing Jetson Nano Dev Kit with R32.7.3 package.

I got below errors after flashing and display is blank:

Failed to Start Docker Application Container Engine.
device-mapper: table: 253:0: thin-pool: unknown target type
device-mapper: ioctl: error adding target to table

Are you using docker as host to flash your board?

If yes, please get a standalone Ubuntu 18.04 as your host PC and use SDKM to flash R32.7.3 to your devkit.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.