SPI Troubles

I am trying to use the GPIO header to power LEDs. I am following a tutorial from AdaFruit (Initial Setup | CircuitPython Libraries on Linux and the NVIDIA Jetson Nano | Adafruit Learning System).

I run: sudo /opt/nvidia/jetson-io/jetson-io.py
I Select Configure 40-pin expansion header at the bottom.
I Select spi1 (19, 21, 23, 24, 26) and then select Back
I Finally select Save and reboot to reconfigure pins . This will create a config file and reboot the Jetson Nano.

I run: ls /dev/i2c* /dev/spi*

I get:
nano@nano:~$ ls /dev/i2c* /dev/spi*
ls: cannot access ‘/dev/spi*’: No such file or directory
/dev/i2c-0 /dev/i2c-2 /dev/i2c-4 /dev/i2c-6
/dev/i2c-1 /dev/i2c-3 /dev/i2c-5

I am expecting more files such as:
/dev/spidev0.0, /dev/spidev0.1, /dev/spidev1.0 and /dev/spidev1.1

I am not sure what I am doing wrong - I have tried doing the process several times. I feel like this might be a permission thing? I have tried to modify permissions of the dev folder (chmod 777 /dev/) but it is not working.

When it reboots, it hangs and says a process is still running and waits for 89 seconds and then reboots.

Any help would be greatly appreciated.

Run below command after reboot

sudo modprobe spidev

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.