Spidev0.0 doesn't show

spi is enabled using the jetson-io.py tool, but /dev/spidev0.0 doesnt show at all.
Looking with dtc at the .dtb files it shows that spi0 and 1 is added.

below is taken from /boot/kernel_tegra194-p2888-0001-p2822-0000-user-custom.dtb, which was generated by jetson-io.py

    spi@3210000 {
            compatible = "nvidia,tegra186-spi";
            reg = <0x0 0x3210000 0x0 0x10000>;
            interrupts = <0x0 0x24 0x4>;
            #address-cells = <0x1>;
            #size-cells = <0x0>;
            iommus = <0x2 0x20>;
            dma-coherent;
            dmas = <0x22 0xf 0x22 0xf>;
            dma-names = "rx", "tx";
            spi-max-frequency = <0x3dfd240>;
            nvidia,clk-parents = "pll_p", "clk_m";
            clocks = <0x4 0x87 0x4 0x66 0x4 0xe>;
            clock-names = "spi", "pll_p", "clk_m";
            resets = <0x5 0x5b>;
            reset-names = "spi";
            status = "okay";
            linux,phandle = <0x16d>;
            phandle = <0x16d>;

            spi@0 {
                    compatible = "tegra-spidev";
                    reg = <0x0>;
                    spi-max-frequency = <0x1f78a40>;

                    controller-data {
                            nvidia,enable-hw-based-cs;
                            nvidia,rx-clk-tap-delay = <0x11>;
                    };
            };

            spi@1 {
                    compatible = "tegra-spidev";
                    reg = <0x1>;
                    spi-max-frequency = <0x1f78a40>;

                    controller-data {
                            nvidia,enable-hw-based-cs;
                            nvidia,rx-clk-tap-delay = <0x11>;
                    };
            };
    };

After J4.6 you need below command to load spidev module. Or you can add it to a start up script for it.

sudo modprobe spidev

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.